Cannot Access Brave Account Page on iPhone

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:

Clicking link to get into account doesn’t work. Brave just has a loading triangle and doesn’t ever progress to account page.

How can this issue be reproduced?

  1. Get email link to sign in (Using Canary email app on iOS)
  2. Click link to login from email Brave sent
  3. Account page doesn’t load. Only see a triangle

Expected result:

Access to my account.

Brave Version( check About Brave):

Version 1.61.1 (24.1.4.20)

Mobile Device details

iPhone 15 Pro running iOS 17.3

Additional Information:
I use Canary for email but links open in all links open in Brave Browser. I do not use in app browser.

Can you share a screenshot of what you see?

How are you getting the link? I want to make sure, you’re going to account.brave.com and having it send email to you?

And you are saying when you click the link, it opens up Brave and navigates there, right?

See here for screenshot:

Yes I am going to the website you listed to login. It sends the email as it should. When I click the “Login to Brave” website I just get the above screenshot. The page stays on that triangle with the purple going around it indefinitely. I have cleared cache, cookies, etc.

Yes, the link opens to Brave Browser.

Thanks for your help.

Ah, ok. I forgot about that ever appearing and was wondering if you just meant the Rewards icon, or what? So glad to confirm that. So I just took my iPhone and went through the process. At first I saw what you shared and it stayed for like 5-10 seconds as something like a loading screen, but then it went to the below:

So if not getting there, one would think it’s an internet problem (including something like a firewall blocking it). Refreshing does nothing either, right? And have you tried changing between wifi and mobile data?

I’m just trying to look and see if can figure out where things might be going wrong and what attempts have been made. If continuing to have issues, I’ll see if can tag anyone on it but not sure what can be done necessarily.

@kewP sorry, just had a moment. Also should ask you to:

  • Disable Shields. Does that change anything?

If no difference:

  • Copy the link instead of clicking on it. Then open private tab on Brave and paste it in. Does that work better?

Thanks for your help I’ve done both of those things prior to reaching out for support. I probably should have mentioned that. Neither of those fixed it.

Sorry, I mentioned 4 things between the two posts. Can you confirm which you’re referencing when saying 2? Or do you mean you attempted all? To clarify, the 4 things are:

  • Opening in Private

  • Disabling Shields

  • If originally opening on wifi, instead use mobile data (turn off wifi) and see if any difference?

  • Double checking you have no firewall, VPN, or internet security apps in place that might be blocking the connection. If so, try disabling (even if temporarily) to see if anything changes.

In any case, I’ll tag in @steeven and @B-Lee to see if they might be able to look and see if there’s anything that might be causing issues or if they might have some specific suggestions for you on how to access your account.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.