Can’t click any links on websites

I really want to use Brave as my default browser, but I can’t click on anything on any sites. For instance, I tried to order shoes from a website yesterday. When I tried to click on the areas to enter in my information, it would not let me, so I had to go back to Safari and order the shoes there. I have had brave for a long time, and forgot why I stopped using , and went back to Safari. This is the reason.

@FatAlex ,

It would help you, to help Brave Support, by editing your OP (Original Post) above, and filling in the details (including screenshots) . . . for the following Report Template:

Description of the issue:

How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Mobile Device details

Additional Information:

And, if / when you someday file another Report (new Topic) here, please select the categories and tags that are closer to the issue that is important to you. Thanks.

Screen Shot 2022-03-05 at 2.48.12 AM

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.