Can not login to wellsfargo.com even after updating browser

Attempting to login to secure bank website www.wellsfago.com via Brave browser, with latest App update applied, from iPhone XR with latest iOS (13.3.1). After selecting Full Site (from the 3 bars top left), then entering login credentials, website states the Brave browser needs updating and is not secure enough to access my online banking.
Checked Brave settings to ensure Java was not disabled. Cleared all Private Data. Restarted App. Settings looked fine. No go.
Added screenshot from wellsfargo.com

Its a bit hard to troubleshoot Banking sites (due to privacy concerns). Does turning off shields make any difference?

I’m not seeing in the iOS app how to turn off shields.

Best Regards,

JAX MEDIA★*This message (including any attachments) contains confidential, proprietary, privileged and private information. The information is intended to be for the use of the individual or entity designated above. If you are not the intended recipient of this message, please notify the sender immediately, and delete the message and any attachments. Any disclosure, reproduction, distribution or other use of this message or any attachments by an individual or entity other than the intended recipient is prohibited. *

Feb 22, 2020, 7:02 PM by brave@discoursemail.com:

Check in the url bar, should have a shields icon, just disable that, and re-test?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.