Can I globally block facebook.com, facebook.net scripts?


#1

win10 brave 0.20.30
I have recently switched to Brave from Firefox with noscript.
I am used to blocking all facebook .com/.net scripts for privacy.
I now see facebook comments in brave, implying the browser is making requests to Facebook and possibly storing cookies.

I do not want to provide any information at all to facebook, although I’ll be content with globally blocking Facebook scripts.

Can this be accomplished in my version of Brave? If not, how can I help make it happen?

Example URL containing unwanted facebook comment script that requests facebook: http://www.planetf1.com/news/haas-unveil-first-challenger-of-the-2018-season/

My shields:


Can we have a Privacy subforum?
#2

If you block scripts globally then it will block on all sites that you visit. Better to block on site that way you can control which scripts to load on the page by clicking on the noscript icon in URL bar.


#3

If I block per-site, doesn’t that require me to load the facebook scripts the first time i visit the site? I’d like to avoid that


#4

There is no setting to set a script from a particular source to be blocked globally. You can however block script globally and on each site allow only the scripts that you want. This would be allowed just once or until restart. This setting for allowing specific scripts won’t be saved permanently. If you enable script blocking per site then it would be saved permanently for that page so each time you visit the site you can selectively choose what script to run.

Global setting -> Blocks everything and you need to change it everytime for all sites you visit
Site setting -> Blocks everything every time for that site and gives you option to selectively run on that site

Hope this helps.


#5

Thank you @sriram I appreciate the details.
I have blocked scripts on http://www.planetf1.com .
I do not see how to selectively choose to run the script for the twitter button without running the facebook comments script.
Is this possible?


#6

You can click on the no script icon in URL bar and then uncheck which you don’t want to run on the page. Here’s a screenshot for reference

Selecing Allow until restart might be a good option if you close the tab


#7

Thanks, that does the trick!


#8

Thanks for confirmation. Will be closing the thread. Please open a new thread if you face any issues.


#9