Can #disable-direct-write flag be added?

windows
#1

Can #disable-direct-write flag be added to brave://flags page?
I’ve heard Chrome had removed this in 2017, but it’s still accessible on Chromium 72.0.3626.121 (Cent Browser latest version).

So far Brave browser is the only one that doesn’t work with mactype font renderer. Font’s are ugly and with jagged edges, especially when lower than 100% page zoom.

Brave
image

Chrome (also looks similar on Vivaldi and Opera; FF has even smoother fonts)
image

1 Like
#2

bumping this thread, because this seems to be an issue with brave browser itself.

#3

@username1,
Thanks for reaching out.
Just curious – do you know for sure that this flag is the cause of the issue (and how do you know)? Not that I don’t believe you, but I want to make sure I understand your thinking here.

1 Like
#4

@Mattches

I’m no expert on this, but
I know this because by disabling windows internal rendering (#disable-direct-write), mactype can fully hook into browser’s exe and render fonts.

Without this option, right now it seems impossible to get mactype working on Brave. I’ve tried many settings, dev and regular Brave, nothing has worked.

Since 2017 chromium-based browsers do not have #disable-direct-write anymore, but mactype has some kind of different way to partly hook into browser, and Brave is the only browser (for some reason), where it doesn’t work (which is the main problem here). Have tried Chrome, FF, Vivaldi, Opera, etc - works everywhere.

Many Chinese and Japanese users have this software because it improves rendering a lot on those characters.

2 Likes
#5

@username1,
Thanks for the information. Let me reach out to the team to see if they have a workaround to suggest and get input on including/surfacing this flag in further releases.

1 Like
#6

Japanese fonts really do look bad in Brave. Definitely need some work around if this browser is to be used in Asia.

1 Like