Camera & Mic Blocked On Pramp Even With Permissions

Description
I cannot use Pramp because the microphone and camera are blocked, even though I had previously enabled these to be allowed on the website.

How can this issue be reproduced?

  1. Have camera and mic access set to Allowed in Brave settings for pramp.com.
  2. Go to www.pramp.com.
  3. Login to the website (this is required to use the site).
  4. Click on your name in the top right to expose a drop-down menu.
  5. Select Camera/Mic.
  6. The camera and mic are blocked on this website.

Expected result:
A small pop-up appears, displaying your camera feed (if there is one), as well as microphone playback, and camera and microphone settings.

Brave Version (check About Brave):
Windows:
Version 1.60.110 Chromium: 119.0.6045.105 (Official Build) (64-bit)
Version 1.61.55 Chromium: 119.0.6045.59 (Official Build) dev (64-bit)

MacOS:
Version 1.60.110 Chromium: 119.0.6045.105 (Official Build) (x86_64)

Additional Information:
The image below (taken on a Windows PC) is the result of the issue.

  • When I tried this in Safari on Mac, it worked just fine.
  • Additionally, when I purposely reset the permissions for the website, it did not prompt me to enable camera and mic access again. I cleared my cookies for the site as well, and this did not work.
  • I also tried opening a session in Zoom from the MacOS browser, and Brave allowed access to my mic and camera just fine, including with the pop-ups asking for permission “until I close this site”.
  • I have used this site on Brave many times before, and I haven’t had this issue. Usually the site gets fussy if Brave hasn’t been updated, but when I updated it the issue persisted this time.
  • Windows Version: Windows 10 Pro 22H2 19045.3570
  • MacOS Version: MacOS Ventura 13.5.2

I am running into the same issue and have not yet found a resolution

@orangexduck and @Mingtendo I just tested and originally was seeing that this indeed was happening within Brave. But then I tested the site on Chrome and the issue happened there as well. It makes it seem like it could perhaps be a Chromium issue. Can you both verify if this issue happens on Chrome?

@fanboynz tagging you in just in case you want to look into it.

I just tested on Brave 1.60.114 on Windows 11 Pro.

Disabling Shields makes no difference. I even went in to toggle the settings on Camera and Microphone to Allow instead of Ask but it made no difference.

But then checked on Chrome and, well…

Yes, this happens in Chrome

Yes, I have had this issue on Chrome as well. It works on Safari on Mac, so probably try that as a workaround? I have inconclusive results with Firefox, however, since my PC does not have a webcam and Pramp simply gave me a different message for it.

Okay, so I would recommend you perhaps create an issue for it over at Chromium, https://bugs.chromium.org/p/chromium/issues/list and New Issue, if you don’t see someone with it open. You’ll have much quicker results from there than you will from Brave trying to handle. You may also want to contact the website itself to advise, so they can have their coders look into it and make any adjustments as necessary.

cc: @Mingtendo @orangexduck

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.