'Call phones' feature in GMail not working in Brave


#1

As far as I can tell, the ‘call phones’ feature* of GMail (a/k/a Google Mail) doesn’t work in Brave.

Everything seems normal, no error messages are returned. However I never hear a dial tone & the call never completes.

A search here did not turn up anything that indicates this is a ‘known’ issue.

Thanks.

  • (originally called “Call Phones From GMail,” now considered part of its ‘Hangouts’ app)

#2

@mk7z, hello! I was able to use Hangouts to call myself from Brave without any issues.
What OS are you using currently? Also, can you ensure that you’ve allowed Brave to access your camera and microphone for that site (if you go to settings -->Security --> Scroll to bottom to find “Saved Site Permissions”)?

Thank you for reaching out!


#3

Thanks. All of those settings had an ‘x’ next to them, which I removed (all of them). That didn’t have any noticeable effect.

For some reason, since I did that I no longer see a ‘Saved Site Permissions’ section listed under ‘Security’ anymore. [?]

I didn’t see anything specific about enabling camera/microphone there. Are those settings perhaps located somewhere else?

I don’t use the actual ‘Hangouts’ app. If you’re phoning directly from Hangouts the situation may be different than calling from GMail (or is the latter what you did?)

I’m using ‘High Sierra’ OS on a Mac.

Thanks.


#4

@mk7z, good catch! I was using the Hangouts app. I tried a few times from my Gmail page and had the same issue you had. Good news is I also found the cause! It looks like Google needs to use fingerprinting methods to identify the device you’re using before the outgoing call can be set.

On your gmail page, open your shields panel (lion symbol on the top right), and under the “Fingerprinting Protection” drop down menu, select “Allow all Fingerprinting”. The page should reload and you should be good to make calls through gmail hangouts as desired :slight_smile:

I’ve attached a gif as well if you’d like to follow the steps in that way.

Thank you for supporting Brave :slight_smile:


#5

Thanks for that, seems to have done the trick.

Any ideas on the odd behavior re the ‘Saved Site Permissions’ category, which I’m now seeing again (it had totally disappeared before) but with only one parameter displayed? (I think there were four originally.)

The only current entry under ‘Saved Site Permissions’ is the one for https://community.brave.com . . . which now has an ‘x’ next to it again, even though I’d removed that after seeing your previous reply.


#6

No problem, happy to help!

When you navigate to a website that requires your permission to perform an action or acquire certain information, you will see a pop-up appear at the top of the screen, asking you to allow or deny permission for [whatever the thing is]. When you do, that site will appear in the “Saved site permissions” section, along with what type of permission was granted.

Example: If you visit www.ign.com and scroll down, you’ll come across a video that, normally, would start playing automatically. When you get to that point, the permissions popup in Brave if you want to “Allow http://www.ign.com/ to auto-play media?” Selecting yes grants permission, the video will begin to play, and navigating to your “Saved Site Permissions” section again will reveal the new permission for ign.com that you’ve just granted. I’ve attached a gif again for your convenience:

Note: If you click the red ‘X’ next to any of the permissions, it removes the permission granted. In our example above, if you were to click the red ‘X’ next to ign.com in the “Saved Site Permissions” and revisit the website, you’ll find that the video once again does not play, and you will be prompted again to allow or deny permission for ign.

Hope this helps!


#7

Thanks, yes, I understand the intent & process. What I didn’t understand was why all those permissions entries disappeared after I clicked the ‘x’ next to them. (I actually just selected ‘Clear all’ to bulk deselect them.)

So IOW, I started with 4 (to my recollection) permissions, which I guess may either be the default or else they were the ones that were automatically applied to my account based on my usage so far.

When I clicked the 'x’s off I expected those entries to remain (just without their x’s). Instead, they all disappeared. Even the category, ‘Saved Site Permissions,’ no longer displayed!

When I checked later, there was only the one entry I mentioned (https://community.brave.com).

I just checked again before writing this and there is still only that one and one other under ‘Saved Site Permissions,’ as shown directly below:

[QUOTE ON]

Show notifications (Clear all)
x https://community.brave.com (Always allow)

Autoplay Media (Clear all)
x https://mail.google.com (Always allow)

[QUOTE OFF]

So I was wondering where the other entries that were originally there went, why they’re no longer there, just minus their x’s, which is what I would have expected.


#8

@mk7z, my apologies, I tend to over-explain things! :sweat_smile:

So if you want the options to reappear in the Permissions section, all you need to do is return to the site(s) in which you want to save permissions for and click “allow” again when the permissions pop-up appears. Then you can find that site in the permissions section.

You’re also asking, and correct me if I’m wrong or misinterpreted your words, why does the site disappear entirely when clearing an entry (via red ‘x’ or ‘clear all’) - which is not the behavior you expected. To me, it sounds like you think the user should have more control over site permissions from within the Brave options provided - in this case, the ability to reapprove/deny/otherwise modify permissions for sites you’d previously given (or denied) permission for.

If my interpretation is correct, then I think you make an excellent point! :slight_smile:
If this functionality is something you would like to see implemented, the best way to let us know is to drop us a feature request/suggestion in the “Feature Requests” category here on Community. Devs and team members prowl here frequently and your request has the best chance of being seen/logged if its made here.

I hope this helps. If not or if you have any further questions, please feel free to reply back here and I’d be more than happy to continue working with you.

Thank you for supporting Brave!


#9

@Mattches - thank you. I had exactly the same issue and prefer using google phone from the browser. Your response helped me make it work. I really like how it was so easy in Brave. Keep up the good work!


#10

So glad I could help!
Enjoy your privacy! :slight_smile:


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.