Built in Importer doesn't import data correctly

bug
#1

Description


Many users have noted that the built in importer used to import browsing data from other browsers doesn’t always function as intended.

This issue is seemingly not dependent on platform, browser being imported from, or browsing data being imported. I’ve created this topic to capture user reports in order to help reveal any common links between them so that we can solve the underlying issue.

What we would like to know


Given that this issue doesn’t seem to have any (obvious) common thread, we would like to consolidate some of this data into a more easily viewable format. If you have (or are currently) encountered this issue with the importer, would you mind replying below and telling us:

  1. What browser were you attempting to import from?
  2. Where you attempting to import all browsing data, or only certain select data? That is – which check boxes were checked when you attempted import?
  3. Of the data selected to be imported, which data (checked boxes) were successfully imported?
  4. Did you try to import selecting only one box at a time? If so, did this work for any of them?
  5. Operating System and Brave version (as always)
0 Likes

How to export passwords/bookmarks
Importing data from chome
Still can't recover my bookmarks
Updates not picking up old settings from 0.25.2
New Chrome Brave will not import cookies, passwords (used built in), bookmarks, more from old Brave
Window 10: Can't Import Bookmarks and Setting from Chrome to Brave
Importing Chrome content not quite right (passwords missing)
Importing Chrome content not quite right (passwords missing)
Brave forgets everything after update
Still can't recover my bookmarks
Brave forgets everything after update
Another "Can't import form Chrome" thread - Passwords or Bookmarks
#2

Hi Mattches - Sorry for my absence. My husband was in bad accident and everything else went by the wayside. I should have time to answer this tomorrow.

1 Like

#3

@BewareTheStober,
My condolences to you and your husband – I hope everything is okay :heart:.
Please take all the time you need and feel free to message me directly or tag me in this (or any post) in the event I don’t see your reply.

0 Likes

#4

even i want the answers to these question.
@BewareTheStober reply whenever you get time.
no hurry.
Thank you in advance.

0 Likes

#5

For me on Linux trying to import from Chromium, I had all check boxes checked and the only thing that was imported was about 15 bookmarks out of a good 30. None of my passwords, history and possibly cookies.

0 Likes

#6

@AndyMcDandyCDN,
Could you answer/provide info on these as well?

0 Likes

#7

I did try just importing passwords since to me, that is more important plus bookmarks can easily be exported to html file and then imported in to Brave.

OS is Kubuntu 18.10 and Brave is of course the latest version which is Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit).

1 Like

#8

From another Community topic

Description of the issue:

I have just migrated from Chrome to Brave and used the “import settings” to import my Chrome stuff. Favourites and other things have imported, but saved passwords did not which is killerrrrrrrrrrrrrrrrrr!

Steps to Reproduce:

  1. Download and install Brave
  2. Menu
  3. Settings
  4. Import
  5. Select Chrome profile
  6. Make sure that “Passwords” is enabled for import

Actual Result:

Check “Saved Passwords” and see nothing is in there :sob:

Expected result:

Chrome saved passwords should also import, not just favourites.

Reproduces how often:

Every time I retry importing!

Brave Version:

0.60.47

Reproducible on current live release (yes/no):

Yes

Worth me also noting - no errors are thrown at all - the import appears to be successful as far as the UI is concerned.


Further detail from the same community thread:

The import was the first thing I did - I had not browsed to any other pages before trying to import.

OS: Windows 10 Enterprise x64
OS Version: 1703
OS Build: 15063.1631

Importing passwords from: Chrome 72.0.3626.121 (Official Build) (64-bit)

Let me know if you need any other info - all bookmarks came through fine, it looks like it’s just the passwords that didn’t :frowning_face:


I just tried this - on my Windows 10 machine (where I’ve had Brave installed for a couple of days now) it did not work at all. I tried:

  • Importing individual tickboxes
  • Importing all tickboxes
  • Importing just passwords

No change in the passwords at all. I even tried with Brave being the ONLY application open on the machine… no success :frowning: despite it giving me the big blue tick - I have all my bookmarks though!

I just did a fresh install of Brave on my MacOS Mojave (10.14.3) machine (never had Brave on it before), closed all browsers first, then launched Brave and did the import and it worked perfectly (it’s probably worth having an instruction pop-up first to say “close all browsers before importing”?)!

Any ideas what I can do to get the import to now work on my Windows 10 machine (I don’t sync between the two - one’s a personal machine, one’s a work machine).

1 Like

Update to latest Brave browser has wiped my saved passwords -AGAIN