Building website, while site server is off Brave will still load up the site randomly


#1

Hello,

I’m trying to use Brave to develop and one of the snags I’m hitting is that I’m not sure what place Brave is storing my website in… I disabled cache but still having an issue where I’ll be working on the website, I turn the locahost server off, and Brave will randomly still show the website if I refresh.

It’s an issue where I’m not confident that Brave is actually looking for the site being served (and containing my latest changes for example) and instead is giving me some cached version of the site.

So the specific way I came across the issue is using npm package nodemon (for serving up local websites). I’ll start off nodemon and my webpage shows up, great. I kill the nodemon process, come back to the site and hit refresh and first it says “a connection attempt was refused”, then I hit refresh again and I see my website! Very confusing. Another hit of refresh and it goes back to connection attempt refused, then another click of refresh and the website is back.

I can’t seem to figure out why it’s doing this, when I test this in Chrome everything works as expected, it always says connection refused when the server is not running.

I’m running MacOS 10.13.3 on a Macbook Pro 2015.

This is my Brave info from about:Brave:

Brave 0.21.18
V8 6.4.388.41
rev 580be78
Muon 4.8.2
OS Release 17.4.0
Update Channel Release
OS Architecture x64
OS Platform macOS
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 64.0.3282.140

thanks,
Iggi