Bug when using "Control you music, videos, and more" button

Description of the issue:
Total collapse of browser usability when using panel under “Control you music, videos, and more” button in specific way. This is the the button encircled in green:
This button usually shows up only when at least one of the tab contains playable media content (e.g. tab with Youtube video).

Steps to Reproduce:

  1. Open Youtube video, play it and pause it.
  2. Open additional tab (content does not matter) and stay in the new tab.
  3. Click on the mentioned button and then click somewhere on the currently opened web page.
  4. That’s it. Now try to browse any website and you see what is happening. I can not even describe it. If there is no problem then in step 2 and 3 use new empty tab with no content or new tab with content.

Actual Result:
Browsing almost not possible. It looks like you browsing simultaneously in main browser frame and also within the panel under the button.

Expected result:

Reproduces how often:
Most of the time. Must follow described steps.

Operating System and Brave Version:
Linux Mint 19.3
Version 1.9.76 Chromium: 81.0.4044.138 (Official Build) (64-bit)

Additional information:
Did not tried to reproduce this in Windows 10. But if needed I can do that.

Thanks for reaching out. Testing on my end, Windows nor macOS reproduce this behavior. Would you mind testing on Windows as you said to see if you can reproduce it? There’s a chance I’m not interpreting the steps you laid out correctly.

I was not able to reproduce it in Windows 10. Looks it works fine there.
But I recorded video of the bug in Linux.

If problem playing it, then download the file and then play.

Yep that’s a pretty intense behavior. Let me reach out to someone more versed in Linux than I and see if they’ve seen this before. Do you have any particular themes installed on your OS?

Nope. But I just found out something.
It seems like when I turn my HW acceleration on [EDIT: I wrote here “off” before by mistake] (brave://settings/system) then I am not able to reproduce the issue. Or I was lucky. I keep my HW acceleration off because of other bug I tackled here: Megathread: For users seeing high CPU spikes/usage
So again: it seems like the issue is present only when HW acceleration is disabled.
And if it helps here are some of my OS and PC specs:

hal@ASUS-N752VX:~$ cat /etc/os-release
NAME="Linux Mint"
VERSION="19.3 (Tricia)"
PRETTY_NAME="Linux Mint 19.3"
hal@ASUS-N752VX:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	LinuxMint
Description:	Linux Mint 19.3 Tricia
Release:	19.3
Codename:	tricia
hal@ASUS-N752VX:~$ hostnamectl
Static hostname: ASUS-N752VX
Icon name: computer-laptop
Chassis: laptop
Machine ID: -
Boot ID: -
Operating System: Linux Mint 19.3
Kernel: Linux 5.3.0-53-generic
Architecture: x86-64
hal@ASUS-N752VX:~$ uname -r

I hope you fix this guys :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.