Bug: Tab: Opens: Link: attribute target="_blank": At Right End Of Tab List Instead Of Next To Tab Containing Link, and Blank Tab Instead of The Linked Web Page (Windows 10)

windows
bug

#1

Thursday, 2018/05/17 @ 03:18 PDT

Bug: Tab: Opens: Link: attribute target="_blank": At Right End Of Tab List Instead Of Next To Tab Containing Link, and Blank Tab Instead of The Linked Web Page (Windows 10)

After updating Brave to the newest version, when left-clicking on a link with the attribute target="_blank", Brave opens a new tab at the right end of the tab list, instead of next to the tab, on the right, that contains the link. In addition, the new tab is blank, instead of containing the linked web page. When right clicking on a link and clicking on the “Open Link in New Tab” in the context menu, Brave correctly opens a new tab, with the linked web page, next to the tab, on the right, that contains the link. Here is an example of the link with the attribute target="_blank", <a href="https://www.brave.com/" target="_blank">Brave Browser Website</a> .

============================================================

Steps to reproduce the bug:

  1. Execute Brave. Brave appears with one or more windows. The next steps all occur in one window.
  2. Open a tab, known as Tab #1, with a web page that contains a link with the attribute target="_blank".
    Tab List: Tab #1.
  3. Open a tab, known as Tab #2, to the right of the previous step’s tab, Tab #1.
    Tab List: Tab #1, Tab #2.
  4. In Tab #1’s web page, left-click on a link with the attribute target="_blank", Brave Browser website.

*** Bug #1: Brave opens a new tab, Tab #3, at the right end of the tab list, which is to the right of Tab #2.
Tab List: Tab #1, Tab #2, Tab #3.

*** Expected #1: Brave opens a new tab, Tab #3, next to the tab, on the right, that contains the link, which is between Tab #1 and Tab #2.
Tab List: Tab #1, Tab #3, Tab #2.

*** Bug #2: The new tab, Tab #3, is blank.
*** Expected #2: The new tab, Tab #3, contains the linked web page

============================================================

About Brave:

Brave: 0.22.714
V8: 6.6.346.26
rev: fa2fbcae947e001528bd3bd5b1c453805d419af6
Muon: 6.0.9
OS Release: 10.0.17134
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 66.0.3359.139

============================================================

.


#2

Hey @rxycf

Thanks for the great write-up. Sounds like this is what you’re facing: https://github.com/brave/browser-laptop/issues/14159

Lauren


#3

Saturday, 2018/06/02 @ 23:48 PDT

@LaurenWags, the bug seems to be fixed in the last update.

============================================================

Brave: 0.22.721
V8: 6.6.346.32
rev: bfe7cdd026c68013236ebe206a33448db9370fca
Muon: 6.0.12
OS Release: 10.0.17134
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 66.0.3359.170

============================================================
.


#4

Thanks for confirming @rxycf,

I’m going to close this thread for now. Feel free to open a new one if you face another issue(s) or have any question.

Thank you,
:slight_smile:


#5