BUG (reproducible): Internal "Save as PDF" feature broken on complex documents (saves everything as images, text is non-searchable)

Description of the issue:
When using Brave’s built-in “Save As PDF” via the Print menu in Windows, the resulting PDF file may be either

  1. searchable text proper pdf file (you can select/copy text and search text within that PDF file, using any standard PDF viewer) → this usually happens when Saving simple web pages as PDF.
    OR
  2. graphics only PDF file, where text is not searchable, no text can be selected (as it is printed/saved as graphics elements, not as a text layer) → this usually happens with longer / more complex web pages, esp. the types that one would like to archive for further study, highlighting as fully searchable and highlightable/copy-capable PDF files.

It is impossible for the user to know, whether the “Save as PDF” feature of Brave produce a PDF file of the type (1) or type (2). One has to manually check it after the creation of the file.

That is, I do not know what is the PDF threshold after which all text is converted into graphics inside the created PDF document.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to any longer / more complex web page using Brave 1.24.64 or later (tested on Windows). For example:

https://answers.microsoft.com/en-us/edge/forum/all/print-to-pdf-generating-bloated-but-unsearchable/15e32194-7bc6-4f57-ad38-abc0b2089e94

  1. Press CTRL+P or select “Print…” from the Brave menu

  2. In the Print dialog windows, for “Destination” select the internal brave PDF saving solution “Save as PDF”

  3. Leave other settings at default (have tried changing other settings, they have no bearing on the end results)

  4. Press button “Save”

  5. Open the created PDF file in any standard compliant PDF reader (e.g. Acrobat Reader DC)

7 .Select the cursor tool in PDF reader and try to highlight/select text (you can’t). Try to search for (CTRL+F) for any text you see visible inside that PDF (for example, the word “and”) and you will get zero hits, as if there is no text whatsoever inside the created PDF file (i.e. it is all converted into non-searchable graphics, not text)

Actual Result (gifs and screenshots are welcome!):

Expected result:
Obviously the resulting PDF file should be such that the:

  • text is fully selectable & copyable within a PDF reader app
  • text can be searched within the PDF reader app

This is NOT a bug of the PDF reader app (have tried seven major standards compliant PDF reader apps, including the built-in PDF reader feature of the Brave browser. Result is always the same : can’t select, can’t highlight, can’t search text).

Reproduces how often:
Always (as long as the Saved as PDF document is complex enough)

Operating System and Brave Version(See the About Brave page in the main menu):

  • Windows 10 Pro 20H2 build 19042.928 x64
  • Brave 1.24.64 Chromium: 90.0.4430.72 (Official Build) beta (64-bit)

Additional Information:
This same feature works 100% in Microsoft Edge v 90.0.818.38 x64. The resulting text is always searchable and can be selected (i.e. there is a generated text layer in the PDF file):

The latest Chrome browser tested 90.0.4430.72 beta channel x64 has the same bug as Brave.

Tested the same “Save As PDF” feature on MacOS 10.14.16 and with Brave for MacOS 1.23.71 (Chromium 90.0.4430.72 Official Build x86_64)

This version of Brave under MacOS produces fully searchable and text-selectable PDF files.

Would anybody care to replicate this on Windows using latest version of Brave (beta, canary or stable)?

@miksituh,
Thank you for reaching out and for writing the detailed report. Please allow me a bit to test the behavior and see what may be going on.

@miksituh,
I cannot replicate this in any way on any PDF. All files/sites download and behave as PDF files including the one you gave as an example. Do you have any extensions installed at this time? One of them may be conflicting with the downloaded site/pdf/file but it seems unlikely.

Hi, yes I have several extensions, but none pertaining to printing or PDF creation .

I will start testing them by disabling them to see if I can make the problem go away.

Confirmed, it seems to be an extension issue.

Now turning them on one-by-one to see which one it is.

1 Like

Yes, found (one of) the culprit extension, it is:

Colorblind - Dalton for Chromium

I have submitted a bug report to them.

Thank you for the help, and sorry for the false alarm!

1 Like

@miksituh,
No worries – I appreciate you digging in and isolating the offending extension without any prompting and for going the extra mile and submitting a bug report to the devs of the extension. Great work :slight_smile:

Please don’t hesitate to reach out if you have any other questions or concerns. Markings this thread as solved/closed now.