Bug report - opening PDFs

Description of the issue:
Nearly every time I click a PDF within a website, a message pops up asking if I want to set Adobe Acrobat at the default in Chrome (yes, Chrome). Even though I click that I want to set it as default, the message reappears in the future. I would like for PDFs to just open without this extra step.

Steps to Reproduce:

  1. Go to a web page that includes a clickable PDF
  2. Click the link for the PDF
  3. Agree to set Adobe as default
  4. Try again – and the message returns, meaning that it did not work to set Adobe as the default

Reproduces how often:
At least daily

Brave version: Version 1.34.81 Chromium: 97.0.4692.99 (Official Build) (64-bit)

I’m using Windows 10

Similar to your issue

Though, I could not replicate your issue after downloading the extension. A pop-up prompt to set it as default never appeared before me.
Some other users might be able to replicate your issue.

Have you gone into the Security and Privacy settings → Additional Content Settings → PDF and set Brave to be the default program for opening PDF within Brave?

That was already selected.

Have I reported this problem in the correct place, or am I meant to report a bug somewhere else? I would really like to find a solution.

This is the correct place. I will tag the brave team members.

First I would recommend updating the browser fully if you haven’t done so already (latest build is v1.35.100 at the time of writing this). As for the issue, I’m not able to reproduce on my end — after downloading the extension, all PDF links open in-browser using the extension.

If you go to the extensions settings, do you have it set to be the default option to view PDFs here?

If so, can you try toggling that option off, then visiting a site with PDFs links, clkcking one, and selecting the Set as default option when prompted. Then, try opening another PDF link and see if you get the same results.

Thank you! I did not have the current version of Brave and couldn’t install it without first uninstalling, so this was a bit of an ordeal. BUT I think it worked! So far so good. With the new installation, Acrobat was not the default. Once I toggled it on, the annoying message stopped appearing. Cautiously optimistic here that I’ve solved the problem, and also that Brave will automatically update itself in the future.


It does automatically update itself if your OS does not limit it, Linux can by default blocks automatic updates while Windows it updates automatically Afaik all major browser automatically update themselves in background and new version is updated every time.

Something odd must have happened for it to not automatically update.

This explains why my auto updates were not happening: https://support.brave.com/hc/en-us/articles/360042816611-Why-isn-t-Brave-updating-automatically-on-Windows-

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.