Bug confirmed: New tabs don't open in desktop view on some websites

android

#1

Brave/Chrome version: 1.0.54/68.0.3440.91
Android 5.0.2

Steps to reproduce the issue:

  1. Set Brave to always prefer desktop view.
  2. Open news.google.com
  3. Make sure you have your Google search setting set to always open links in a new tab.
  4. Tap on any link.

Expected behavior:
The tapped link will open in a new tab that is in desktop view.

Actual behavior:
The tapped link will open in a new tab that is in mobile view.

Additional information:
Brave shields are set to HTTPs Everywhere and to block third party cookies. So far I have seen this behavior on on news.google.com. Other websites that open links in new tab will do so in anew tab that is in desktop view.


#2

Interesting, I’m not able to reproduce.

@Mattches are you able to reproduce this one?

Thanks,
Lauren


#3

Sorry for the late reply!

I am unable to reproduce, using my Galaxy S9, Android 8.0 on Brave V1.0.54.
Would you mind telling us what type of phone you’re using?


#4

Sure, it’s a Samsung Galaxy Note Pro 12.2 SM-P900 tablet with Android 5.02. So far this issue only appears at news.google.com. Links opening from other websites are fine and will open in an new tab in desktop mode.


#5

I’d like to give a little bit more details on this issue:

Google has recently changed its news site. News.google.com used to load in an instance even on slower devices. Not anymore. The new design has apparently introduced a lot more java script which is slowing rendering times considerably - especially on slower devices like mine.

When I open news.google.com my tablet need about 20 to 30 seconds to fully load and render everything (used to be less than 5 seconds).

If I click on a link while the website is still loading or rendering this link will open in a new tab in desktop view. If I wait for news.google.com to load and render fully and click on a link after rendering has finished the link will open in a new tab in mobile view.

If I deactivate java script news.google.com will load in about 3 seconds or so. But still links clicked will open in a new tab in mobile view.

Maybe it has something to do with the new design - I’m actually quite sure about this. Every link you click in news.google.com will open a website within the Google domain like https://news.google.com/articles/CAIiEGlmypyg11n
This site will then redirect to the actual website.

On news.google.com Brave shields only block third party cookies. Additionally I have https everywhere active.


#6

@Mattches Try this example:
Example

Set Brave to always display tabs in desktop view. Navigate to the example and click on it. It will open a new tab in mobile view.

Tested here on Android 5 with Brave 1.0.57.

BTW: Clicking on the link above will already open a new tab --> in mobile view and not desktop view.
PS: Now as I’m testing it the vast majority of websites opening in a new tab will open in a mobile tab. So it is not an exception but almost default. An example that works correctly: Go to startpage.com and set it to open search results in a new window. Then search and open a test result. The newly opened tab will be in desktop mode.
PPS: @LaurenWags can you reproduce it using the above link?


#7

Here’s what I did to test:

  • Visited news.google.com - displayed in mobile view
  • Searched for news.google.com and opened link in new tab - displayed in mobile view
  • Opened links in tab and as new tab from news.google.com - displayed in mobile view
  • Opened links in background - displayed in mobile view
  • Enabled “Desktop view” for news.google.com and repeated above steps - displayed in desktop view

I tested the same series of steps with startpage.com with the same results. @Brave_user, I apologize but I’m still unable to reproduce any of what you’re describing. Can you take a screenshot of some of the web pages you’re seeing displayed in desktop view?


#8

@Mattches startpage.com does work. That was the positive (i.e. actually working) example. Please try the link named “Example” in my above post.


#9

So navigating to Settings --> Site Settings --> Desktop Mode reveals an option worded as follows:

Desktop Mode
Enable Desktop View for new tabs

I would like to emphasize the “new tabs” part of the description. In the example above, when you click the JavaScript Window Example 1 link on mobile, the link opens a new tab and displays in Desktop mode as expected. When the “Using the window.open method” is clicked, the link is opened in the same tab and is displayed in mobile view. This is why I emphasized the “new tab” portion of Desktop Mode.

I can’t say exactly why it is done this way (will reach out to Android team for more info) but given the wording and behavior shown I don’t think this is acting in any “unexpected” way (although it may be confusing). If you click the second link in your example and it opens in mobile view, opening the menu and checking the “desktop site” box will display the page in desktop view. Additionally, if I long-press the second link and elect to open it in a new tab, the page is displayed in desktop mode as expected. Short recording for confirmation:


#10

@Mattches Sorry, I’m not quite sure whether or not I understand you correctly.

I have Brave set to always open new tabs in desktop view. My example link point to http://javascript-coder.com/files/window-popup/javascript-window-open-example1.html. There the first link on the website (the first line) is called “Open the JavaScript Window Example 1”. If I click this specific link a new tab is going to be opened … in mobile view. At least on my Android 5 with Brave 1.0.57 and on my Android 6 with Brave 1.0.57. One is a smartphone and the other a tablet.

This behavior is the same on most websites that open a clicked link in a new tab. Some however, like startpage.com, behave correctly by opening a new tab in desktop view. That is also true on both of my devices (android 5 and 6 respectively).

Long pressing a long and selecting “open in new tab” will always open a new tab in desktop mode. It seems only tabs opened by a website function suffers from this problem.


#11

@Brave_user, if you have desktop view enabled, then any new tabs opened will display in desktop view. If I enable the view, then navigate to your example and try both links,here’s what I see:

This is showing all windows navigated to (including Community) displayed in desktop view. Try enabling desktop view, opening a new, fresh tab, navigate to your example website and try again. Do you get results that match mine?


#12

@Mattches here is what I did on both devices:

  1. Enable settings --> site settings -->desktop mode for all new tabs
  2. Opened a fresh tab
  3. Navigated to http://javascript-coder.com/files/window-popup/javascript-window-open-example1.html
  4. Clicked the first link on that website named “Open the JavaScript Window Example 1”
  5. New tab opens I mobile view.

#13

Can I see a screenshot of the mobile view?


#14

@Mattches here are two screenshots. First is from the website http://javascript-coder.com/files/window-popup/javascript-window-open-example1.html snowing that Brave displays this website in desktop mode. It a German locale but I think you can see the check box there for desktop view.

Second Screenshot is the website that will open when I click on the first link on the above mentioned website. It shows that the newly opened website is in mobile view (i.e. check box is not checked).



#15

@Brave_user, I’d like to thank you for being patient and working through the issue with me. This may seem anti-climactic but the end result of this is: you found a bug! I’ve spoken to our Android team and they had me log an issue for it with your report included. You can see it here: https://github.com/brave/browser-android-tabs/issues/740

Again, I appreciate you sticking with it and helping me dig out the issue. Unless you have further comments/questions regarding it, I’ll be closing this topic. Additionally, if you have other questions or support requests, feel free to open a new topic for them.


#16

Late to the party, but big thanks to both of you for working thru this and getting to the bottom of it! :heart:


#17

Thanks so much @Mattches, nothing anticlimactic about it. I’m glad you were able to confirm a bug. I mean this section of the community is all about bugs. So the outcome is absolutely fine.

You can close this thread now. I’m going to edit the thread title to reflect the outcome of our discussion.


#18