[Bug and reason] snap version of Brave has problematic Asian language support

Description of the issue:

Some Asian languages such as Japanese or Chinese needs input methods in Linux. The most popular input methods are now fcitx, fcitx5 and ibus. GNOME desktop environment uses ibus as default. However , snap version of Brave only support fcitx, so ibus do not works on it, which makes gnome desktop user hard to use Brave from snap.
Snap of Chromium has no such problem.

How can this issue be reproduced?

  1. Install OS like Fedora choosing Chinese or Japanese or Korean language
  2. Install snapd
  3. Install brave for snap

Brave Version( check About Brave):
V1.38.111