Browser worked slow

Sometime i face some problen when i browse too many thing then it work slow sometimes please slove this

Go to brave://settings/system

Disable hardware acceleration. Use it for a few days and check if it makes a difference.

1 Like

Hello @Zunaed003, thank you for reaching us out. Additionally, you can try the following setting:

What kind of device are you using? If on desktop Go to brave://flags > Search 'Vulkan' >Disable > Vulkan > Retest

Let us know if this is still an issue. Regards.

Holy Sh*t! this made a f**kton of a difference! Thanks for the advice!
I am a tech noob and was going crazy wondering why Brave browser suddenly became so heavy and slow.
Almost made me quit the browser!