Browser not working

Idk if it happened because I added an app limit in the screen time settings in my iPhone but the browser is really slow and its not my internet connection because chrome works fine.

@SLicea10

iOS Settings > Brave

  • Disable the Siri & Search settings
  • Disable Notifications
  • Disable Background App Refresh

Brave Browser iOS > Settings

  • Disable VPN
  • Disable Playlist
  • Disable Wallet (Beta)

FEATURES

  • Disable Brave News
  • Disable Firewall + VPN

GENERAL

  • Disable Sync

Brave Shields & Privacy > CLEAR PRIVATE DATA

  • Enable all switches

. . . and Clear Data Now

OTHER PRIVACY SETTINGS

Enable Private Browsing Only

Try to use Brave Browser iOS, visiting websites.