Browser not responding when clicking on button

Hi the last two days Brave isn’t responding to some button click. To upload file and do download. Seems to be working fine when I switch browsers. Any suggestions?

Version 1.47.171 Chromium: 109.0.5414.87 (Official Build) (arm64)

Also just tried to download latest version of Brave and doesn’t automatically download. Just stuck in loading…Tried to download manually, nothing happens…

Hello @DecentralizedMe

Thank you for reaching us and I’m sorry to hear you are going through this. Please try In Private mode or Guest Window to see if the behavior persist . If that works, try disabling your extensions to see if this is the cause of the issue.

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Be waiting for your response!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.