Browser not loading pages


Description of the issue:

I just switched over to using the Brave browser yesterday (6/2/2021). When I turned on my laptop today, I found that many pages would not load. Search engines and low traffic websites would load a little bit, but big, high traffic websites would not load at all, such as YouTube and Twitch. I restarted my laptop twice, as well as I cleared the browser cache but the problem persists.

UPDATE I have found that sites will not load when “block scripts” is enabled.

How can this issue be reproduced?

  1. Turn on laptop
  2. Open the Brave Browser
  3. Attempts to load a commonly high-traffic website.

Expected result:

The page will have a persistent loading indicator and the page will not load.

Brave Version( check About Brave):

Version 1.25.68 Chromium: 91.0.4472.77 (Official Build) (64-bit) (https://brave.com/latest/)

Additional Information:

I did do some research and found two other topics about this issue but I could not find any answers within them. From what I saw, at least one of them was closed but not resolved.

The vast majority of websites rely on JavaScript to work properly, so blocking JavaScript (what the mentioned option does) is very likely to give you troubles. I would advice you to go to brave://settings/shields and make sure “Block scripts” is disabled, that will allow JavaScript on a global level.

1 Like

@Rethanis I second your last reply.
@dylanrb14 it may also be useful to read up on how Shields work to avoid issues like this in the future: