Browser crash when accessing cookies and site data

My browser fully crashes when I click on the “cookies and site data” button in the site information menu on any site that it appears.

As soon as I click “cookies and site data”, it crashes without furthering the menu process at all.

Running on Brave Version 1.61.101 Chromium 120.0.6099.71

This occurs on both sites that I have previously visited, as well as site that I have never visited, with no prior cookies or site data.

1 Like

same here, i made a topic on their Github page and no response still, it used to work fine before the latest update.

tried disabling all extensions, resetting all brave://flags settings, nothing.

1 Like

Same here. Ridiculous that this browser is glitchier than Chrome. What could they be doing to cause these types of bugs?

facts, vanilla chromium is perfect but these guys have to break stuff with every update It’s so tiring. There is a bug that makes some extensions not work properly and require reloading every time you launch the browser, The bug is well known, yet it still hasn’t been fixed for months now. RIDICULOUS…

@Persesco @stanley2884 @dsae

For those of you who haven’t yet, make sure you put which version of Brave you’re using as well as which OS. (Do a favor, instead of just saying Windows, say which iteration. Such as Windows 10, 11, etc)

Also want you to do the following, one step at a time and in this order:

  1. Go to brave://crashes and copy/paste any Uploaded Crash Report ID you have. If it is indeed crashing, you should have reports there. Do keep in mind if it says Send Now, then you will need to click that and exit the browser for like 20-30 seconds or so as crash reports only upload while Brave is closed. (This will let devs know more of what is going on.)

  2. Create a new profile (secondary test profile). Hamburger Menu imageMore ToolsAdd new profile. Test on that, making sure not to add extensions or change settings. See if the issue happens in new profile as well.

3, Go to brave.com/download and download Brave again. To be clear, I’m not telling you to uninstall or clear data. By downloading and installing it again, it can patch files and fix anything that might be corrupt.

  1. If this is still happening in steps 2 and 3, download Brave Beta or Brave Nightly and see if you experience this same issue there.


Already tried reinstalling brave it doesn’t work, the bug doesn’t occur on other profiles for some reason.

My OS : Win10 22H2 build 19045.2486
Brave version: “stable” v1.61.101

If it works well in a new profile, then generally it means it’s either an extension that’s installed, cookies/cache, something in your settings, or somehow you just have an issue in your profile where something is corrupted, basically.

I forgot to look while I was on my computer if that button exists when you’re in a private window. If it does, then, perhaps you should try on a private window on that original profile and see if that causes the crash to occur as well. That would at least narrow it down to cookies or extensions if it does.

In any case, I am responding from my phone right now. So I’ll leave it to you to kind of glimpse around and see what you can test. I’ll try to check in with you all tomorrow.

@dsae also, not to be picky or annoying, but if you can copy/paste instead of screenshot on crash report it helps devs. Otherwise they have to kind of zoom and try typing it out. Definitely takes longer and leaves margin of error that way, so helpful to them if you can. (And should be simple from PC as well)

as i mentioned before i already tried disabling all extensions. and yes the crash also occurs on private mode which proves it has nothing to do with cache/cookies.

sure here’s the ids:

Crash from Sunday, December 10, 2023 at 9:49:48 PM

Status: Uploaded
Uploaded Crash Report ID: ac370a00-8bde-260b-0000-000000000000
Upload Time: Monday, December 11, 2023 at 3:50:42 AM
Local Crash Context: fd796718-7e6f-4325-8d9a-55be3e1bd5d7

Provide additional details

Crash from Sunday, December 10, 2023 at 9:42:54 PM

Status: Uploaded
Uploaded Crash Report ID: a8370a00-8bde-260b-0000-000000000000
Upload Time: Monday, December 11, 2023 at 3:50:41 AM
Local Crash Context: 0ac129e8-6019-4e23-b088-a862a50f67fa

Provide additional details

Crash from Sunday, December 10, 2023 at 9:11:10 PM

Status: Uploaded
Uploaded Crash Report ID: a7370a00-8bde-260b-0000-000000000000
Upload Time: Monday, December 11, 2023 at 3:50:40 AM
Local Crash Context: 36510571-10ea-4890-b2b1-6b9a76a581f0

Provide additional details

Crash from Sunday, December 10, 2023 at 6:24:13 PM

Status: Uploaded
Uploaded Crash Report ID: a5370a00-8bde-260b-0000-000000000000
Upload Time: Monday, December 11, 2023 at 3:50:39 AM
Local Crash Context: 9b8a720c-4f51-4380-8309-2f1fcb4d2a28

Provide additional details

Crash from Sunday, December 10, 2023 at 6:18:38 PM

Status: Uploaded
Uploaded Crash Report ID: a3370a00-8bde-260b-0000-000000000000
Upload Time: Monday, December 11, 2023 at 3:50:38 AM
Local Crash Context: 826eb292-77f8-46d0-81bf-cea709f0a6bc

Provide additional details

Crash from Sunday, December 10, 2023 at 6:18:19 PM

Status: Uploaded
Uploaded Crash Report ID: a2370a00-8bde-260b-0000-000000000000
Upload Time: Monday, December 11, 2023 at 3:50:38 AM
Local Crash Context: 95f37561-cd35-41d6-a5db-1069be9927ab

Provide additional details

Crash from Sunday, December 10, 2023 at 6:17:43 PM

Status: Uploaded
Uploaded Crash Report ID: a1370a00-8bde-260b-0000-000000000000
Upload Time: Monday, December 11, 2023 at 3:50:37 AM
Local Crash Context: dfa95822-3ce0-4075-a321-06a0afcdcc1b

Provide additional details

Crash from Sunday, December 10, 2023 at 6:15:18 PM

Status: Uploaded
Uploaded Crash Report ID: 9d370a00-8bde-260b-0000-000000000000
Upload Time: Monday, December 11, 2023 at 3:50:36 AM
Local Crash Context: 5e0864ce-c8b0-4cb4-94c7-22d4564c8764
1 Like

Right, which confirms not extensions (unless you set to run in private) and shouldn’t be cookies related since private opens with no cookies.

So it’s settings or corrupt profile. Something changed in settings seems more likely but have to figure out what.

Anyway, I’m going to bed. Will check in later. Maybe one of you will get to checking and figure it out. I’d almost want to start with Privacy or Shields settings, especially if you’ve blocked cookies or something.

alright man thank you so much for your time. i hope devs will notice it and hopefully fix it soon unlike the other chrome.declarativeNetRequest bug which still persists despite months passing and numerous reports from people.

i tried playing with shields settings to no avail. it’s 100% a browser issue and it started occurring since the last update it has nothing to do with my main profile being corrupted or anything like that.

@Mattches you have any ideas? Also curious if you can check into the Uploaded Crash Report IDs they shared just above.

And yeah, @dsae, so far all the changes I tried making to replicate haven’t really mattered as it’s not crashing. If you’re up for it, perhaps can try to put Brave settings back to default and see if this resolves for you. Can do that at brave://settings/reset. This will change everything back to default. It won’t uninstall extensions but it will disable them. That said, it will clear out cookies and all. So means likely have to login to everything again.

Sharing these IDs with the devs — will have more information soon.

When I went to brave://settings/cookies and blocked third party cookies, this problem went away. Nothing else suggested above worked.

@K-G-C are you saying you tried new profile and it was still crashing?

The new profile worked as far as not crashing. But when I had a new profile, I lost access to all my bookmarks. I have an extensive set of bookmarks and don’t want to lose access. I am still worried that certain cookie driven things won’t work now that I have third party cookies blocked. I should say that I routinely delete cookies on a per website basis in order to bypass paywalls. Apparently someone created a third party cookie that kills access to the “view site information” icon in the URL line so people can’t kill site cookies and bypass paywalls. …Which in turn begs the question, how do we notify Brave developers that this is going on? Presumably the developers can do something about it?

Also… By default I have “cross site cookies” blocked on a per site basis. But apparently that doesn’t specifically block “third party cookies”. I am not savy enough to know how all that sort of thing works.

Also… Given that opening a new profile works, I am going to try to figure out how to copy my bookmarks to a new profile. If you have any hints, I would appreciate it.

Which cycles back around to the conversation I was having with dsae before you posted. If it works in new profile it means that there’s most likely an extension or setting causing your problem. If we can just figure that out, then your issue would go away.

If you’d prefer to do that, you could either create a sync chain between your profiles or you can just import/export any passwords and/or bookmarks.

@K-G-C,
Cross-site cookies are third party cookies. And to confirm, you’re saying that opening and using a new profile works when you try to view cookies/site data internal pages — but it still isn’t working in your original profile, right?

1 Like

the issue has been fixed, we need to wait for next version now :

1 Like