Browser crash upon opening

bug

#1

Using Mac iOS 10.9 on my computer
i. I clicked on Brave browser as usual
ii. When I opened the browser, I got the following error message "Brave quit unexpectedly"
iii. I followed the FAQ, deleted the browser in applications, and entered the text as directed into the terminal application
iv. I restarted the computer
v. I re-downloaded Brave, but the same thing happened (browser crashed upon opening with the same error message)

Now Brave crashes every time I try to open it. Any help would be appreciated.


#2

I have the exact same thing happening with my Mac. I just described my issue on another active thread on this site (“Most recent version (0.19.139) of Brave crashes on launch”). In that thread, a suggestion was made to download an old version of Brave, with the necessary link provided. That only worked temporarily, at least for me.


#3

This suggestion worked, thanks so much!

I guess my next question is, when can I update my browser again? In a couple of weeks with the new update?


#4

Looping in @LaurenWags on this. :slight_smile:


#5

@kiwi-person, does your Mac maintain the older version of Brave after you downloaded it? It doesn’t stay when I download it; as soon as I log off of Brave, the new version with the glitch (0.19.139) automatically takes it’s place, even though I’ve deleted the new version. :frowning_face: Hope a fix for the issue will occur soon; really miss the Brave browser - I’ve had to go back to Firefox. Like you, I’m wondering when we’ll know when we can safely update the browser.


#6

can confirm same thing happening for me…

osx 10.9.1 (happen to be running a hackintosh).

thx, guys, love your work! =)


#7

would be quite helpful if you could provide a link to that thread or to the download of the old version you mention…


#8

This one @starfury :slight_smile:


#9

@mbgdriver and @kiwi-person We have an issue logged and are looking at it. I hope to have an update soon.


#10

Also, this is the issue we have logged, which you can follow:


#11

@LaurenWags, Thank you!


#12

Downloading and installing the v0.19.134dev solved my problem. Thanks.


#13

Wait! it only worked once. Now it crashes again so the problem is not fixed.:expressionless:


#14

No it doesn’t maintain the version. Same thing happens to me. So I guess we’ll have to wait patiently for an update! :slight_smile:


#15

@kiwi-person Yep I think so.
@LaurenWags


#16

No news yet @mgbdriver :frowning: We’re still working through this issue. There have been a couple of test builds but still appears to be crashes. Definitely keep an eye on the logged issue.


#17

Thanks for the update! @LaurenWags


#18

For anyone interested - cross-posting:


#19

@LaurenWags, Nope sorry it didn’t work. Crashed immediately (0.19.146dev). :slightly_frowning_face:


#20

Thanks for reporting back @mgbdriver - bummed to hear that. Will share your results with the team.