Brightness decreases When Youtube is full screen

Brightness decreases When Youtube is full screen. This topic was closed years ago for some reason so I couldn’t find a solution. Only happens with Brave not Chrome Firefox or Edge.

@Kasparrov95 you on a laptop?

Yes. But this issue started today for some reason.

It’s a surface laptop 4

Not sure why it would just suddenly start today. What I was going to suggest was to go look through things like your battery saver and all. It’s been a long time since I used a laptop but I know at one point I had seen where you could adjust how much power would be used even with specific apps/programs. Guess I was really putting primary focus on if it was doing that with Brave for that purpose.

But then when I just went to research a bit on your answer, I saw https://support.microsoft.com/en-us/surface/adaptive-brightness-and-contrast-on-surface-devices-7936a0b4-93ec-b010-9892-9987143eb88f and am wondering it that perhaps might be what you’re experiencing. It’s related to what I had mentioned but is slightly different.

Could you try taking a look at those and see if there’s any impact if you make changes? Primarily, curious about disabling things like battery saver and/or adaptive brightness.

What’s the article that you shared and that stuff that I’ve already done. I’ve done everything from download group Policy edit for my laptop to reinstalling Windows 11. But then come to find out this is a brave issue. An issue with the brave browser because as I said Chrome Firefox edge Opera they don’t do that. It’s specifically happens when I watch a YouTube video and I make it full screen. It dims then when I make the screen smaller again it goes back to being bright and then I make the screen big again and it dims again. So it is related to making the screen bigger. I don’t understand what the issue is but it is absolutely exclusive to brave and I’ve tried everything.

Okay, so you have completely disabled adaptive brightness?

I just want to confirm I’m not misunderstanding. I do know you’re saying this is impactive Brave only. I’m just trying to narrow down things possibly contributing.

I’m also going through things like https://answers.microsoft.com/en-us/microsoftedge/forum/all/screen-brightness-dims-completely-when-going/1ab98a10-73c1-4735-9258-8b18f01d98d3 where someone had an issue with Edge. What kind of can make things challenging though is like the person with the issue was automatically dismissive to anything they were told to check, as they thought 100% sure it was only an issue with Edge. And because nothing was tested or reported back, they didn’t seem to ever get to an answer.

It does go to show though that this has been an issue since at least 2022 and may not be limited to Brave, even though you’re saying Brave is the only one you’re experiencing this issue with.

Some information needed:

Aside from asking about adjusting the settings and all, can you make sure to share:

  • What version of Brave are you using? (please share exact version number, don’t just say “the latest”)

  • Which version of Windows are you using? (10, 10 Pro, 11, 11 Pro, etc)

  • Looking at link about Edge, someone mentioned issue only happened when plugged in. Can you advise if the behavior changes if plugged in vs on battery?

  • Does this only occur on YouTube or any website where you put a video to full screen?

  • Are you using any extensions on Brave?

I walked through with a Microsoft IT agent to make sure all my adaptive brightness settings were off. To answer your questions

  1. 1.62.165
  2. Windows 11
  3. Issue only happens when plugged in.
  4. Issue happened when playing any video not just youtube.
  5. Extension used- ublock origin. I removed it but issue persists.
1 Like

Thanks for that. A lot of what I’m working on with you is a bit of triage. It’s looking at some of the basic steps and gathering some info so @Mattches and others can come in and hopefully give some more solid guidance.

The things haven’t yet asked you and I should have is if you’d be willing to try three more steps.

  1. Open in private window. Does this change anything?

  2. Add a new browser profile. You do that by going to Hamburger Menu imageMore ToolsAdd new profile. This will create a secondary profile with default settings overall and no extensions.

  3. Could you install Brave Beta or Brave Nightly and see if the issue happens there?

To explain what those three look at:

  1. Checks cookies as should open with no cookies. Also is a partial check against extensions as it should disable any.

  2. Checks browser settings, cookies, and extensions. Comparing and contrasting results against private helps point in the right direction

  3. Primarily checks if it’s version specific. If things work well in one version of Brave but not another, it helps to narrow down possible issues based on what had been changed.

Then typically would ask you to test on Chrome, but you said you’ve already checked and it’s not happening on Chrome or Firefox.

Of course id be willing to try anything to keep Brave as my default.

  1. Opening in private tab doesnt fix. Issue persists.

  2. Adding a new profile didnt do anything. Issue persists. Even tried the private window on new profile. Issue persists.

  3. Brave Beta worked like a charm. Brave Nightly worked like a charm.

1 Like

Honestly I’m at a bit of a loss here. To me it seems like it would be a system issue but if you worked through this with an MS agent then that’s likely not the case.

Additionally, if the issue occurs on the stable version of the browser you would expect it to occur in Beta and Nightly builds as well.

Did you by chance set/change any flags in the browser (brave://flags)? Going to have to ask some other team members about this as I am not sure what else to suggest.

i dont know. how can i find out?

Simply go to brave://flags — typically any flags you’ve changed will appear at the top and highlighted blue, as shown here:

I have a lot enabled by default. Can i share them somehow so you know which ones?

I was just trying to look through to see what similar issues had been noticed. One of them is as follows:

This is kind of like what we’ve touched on before, but wanted to share as steps are slightly different. I’m assuming may not have any impact for you, but at least wanted to put it out there rather than make an assumption and not share a possible solution.

That option may not be in windows 11 cause i dont see anything that says “Brightness and color” When I click on “Brightness” and “Color” individually, that option is nowhere to be found.

@Kasparrov95,
Any flags you have changed/enabled will appear at the top of the brave://flags page — observe the dark-blue color of the enabled flags:

Ok then I dont have any enabled

same problem for me . it occurs only when playing videos while plugged in.

besides this is one of the most significant bugs for a long time on windows now .

https://www.reddit.com/r/brave_browser/comments/gofv2t/fullscreen_video_autobrightness_problem/

@kartiksharmakk been a long time, but people also been reporting it on different browsers as well. It seems to be a device setting issue, but it’s having to figure out what/where.

https://answers.microsoft.com/en-us/microsoftedge/forum/all/screen-brightness-dims-completely-when-going/1ab98a10-73c1-4735-9258-8b18f01d98d3

https://groups.google.com/g/iterm2-discuss/c/n-HPXNJwmbU

https://h30434.www3.hp.com/t5/Notebook-Video-Display-and-Touch/Screen-Dimming-when-watching-a-video-on-full-screen/td-p/7809478 (though this one in description is a bit different, as they went from speaking of dimming brightness to then also speaking of grainy picture)

What I will say is many of these issues where people claim to have resolved it comes down to them saying that the brightness settings for full screen is different than normal. So if you will manually adjust brightness in full screen, it will keep the setting you have chosen the next time.

1 Like