Bright flash in Darkmode

Description of the issue:
While using darkmode, if you refresh a page, which is also in darkmode, for a short moment the page will turn white (flash) until it’s back to the darkmode again.
Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Enable dark mode in Brave 2. Enable darkmode on the webpage f.e. twitter.com (you have to be logged in for changing to darkmode, but I guess there are other pages where you can try darkmode without having to log in 3. Refresh page
    Actual Result (gifs and screenshots are welcome!):
    The page flashes and it can hurt the eyes.
    Expected result:
    It would be nice to have a black or dark gray page while refreshing a page while you are in darkmode
    Reproduces how often:
    All the time
    Operating System and Brave Version(See the About Brave page in the main menu):
    MacOs. Brave version 0.66.99
    Additional Information:

I use Version 0.67.124 Chromium: 76.0.3809.100 (Official Build) (64-bit) on macOS 10.14.6 (18G87) and have no problem with using dark mode. I use it everywhere it’s available, so I would have noticed!
Maybe this is a GPU related bug? Have you tried to disable Hardware Acceleration in the extended part of Brave’s settings and see if the problem persists?

Also, do you have a Mac with swichable graphics? Have you enabled the Automatic Graphics switching?
I always leave this off, as I use other apps that sometimes have trouble with this setting…

This topic was automatically closed after 30 days. New replies are no longer allowed.