Breaks other applications: OSX

#1

If Brave is installed on my MacBookPro, two applications (VisualStudio Mac, BlueGriffon) I use regularly fail to function correctly. Removing Brave and rebooting fixes these issues. Reinstalling Brave and rebooting returns these issues.

Symptoms:

  • VisualStudio Mac: Unable to close tabs, unable to expand or contract folders or projects in solution explorer.
  • BlueGriffon: Application crashes when trying to save a new file. Exception: ‘NSAccessibilityException’, reason: ‘“AXSubrole” attribute unsupported by: <BaseWindow: …’

Version Information

Brave

This is with the latest stable release of Brave (as of 3/7/2019).

VisualStudio Mac

=== Visual Studio Community 2017 for Mac ===

Version 7.8.2 (build 1)
Installation UUID: c3c61da2-4d87-4c39-b8d3-9fbf7e6af430
GTK+ 2.24.23 (Raleigh theme)
Xamarin.Mac 5.0.0.0 ( / b40230c0)

Package version: 518000248

=== Mono Framework MDK ===

Runtime:
Mono 5.18.0.248 (2018-08/a4956c837e1) (64-bit)
Package version: 518000248

=== NuGet ===

Version: 4.8.0.5385

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
2.1.8
2.1.7
2.1.6
2.1.2
2.1.1
2.0.5
2.0.0
1.1.1
1.0.4
SDK: /usr/local/share/dotnet/sdk/2.1.504/Sdks
SDK Versions:
2.1.504
2.1.503
2.1.500
2.1.302
2.1.301
2.1.4
2.0.0
1.0.3
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.18.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.6.4
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Updater ===

Version: 11

=== Xamarin.Android ===

Version: 9.1.8.0 (Visual Studio Community)
Android SDK: /Users/ben/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
2.3 (API level 10)
4.0.3 (API level 15)
4.4 (API level 19)
5.0 (API level 21)
5.1 (API level 22)
6.0 (API level 23)
7.0 (API level 24)
7.1 (API level 25)
8.0 (API level 26)
8.1 (API level 27)

SDK Tools Version: 26.1.1
SDK Platform Tools Version: 28.0.1
SDK Build Tools Version: 28.0.3

=== Microsoft Mobile OpenJDK ===

Java SDK: /Users/ben/Library/Developer/Xamarin/jdk/microsoft_dist_openjdk_8.0.25
1.8.0-25
Android Designer EPL code available here:

=== Android Device Manager ===

Version: 7.8.1.0
Hash: 8924ea4a

=== Apple Developer Tools ===

Xcode 10.1 (14460.46)
Build 10B61

=== Xamarin Inspector ===

Version: 1.4.3
Hash: db27525
Branch: 1.4-release
Build date: Mon, 09 Jul 2018 21:20:18 GMT
Client compatibility: 1

=== Xamarin.Mac ===

Version: 5.2.1.15 (Visual Studio Community)
Hash: d60abd198
Branch:
Build date: 2019-02-01 12:23:30-0500

=== Xamarin.iOS ===

Version: 12.2.1.15 (Visual Studio Community)
Hash: d60abd198
Branch: d15-9
Build date: 2019-02-01 12:23:29-0500

=== Build Information ===

Release ID: 708020001
Git revision: 13e0e5b7e85ffe742957e6f204bab5c06c644f0e
Build date: 2019-02-27 19:33:14+00
Build branch: release-7.8
Xamarin extensions: 23eaa7c9cdc9a3f55be7bb87b485a790ec82ef25

=== Operating System ===

Mac OS X 10.14.3
Darwin 18.2.0 Darwin Kernel Version 18.2.0
Thu Dec 20 20:46:53 PST 2018
root:xnu-4903.241.1~1/RELEASE_X86_64 x86_64

=== Enabled user installed extensions ===

Android Signature Tool 2.1.2
Archiver 1.0
MSBuild Editor 2.1.0
NuGet Package Explorer 0.2
Open With 0.1
NuGet Package Management Extensions 0.15
WakaTime 3.0.5
xUnit.NET 2 testing framework support 0.7.5
Show in Github 1.0.4
DeepClean 1.2.4

BlueGriffon

version 3.0.1
build 20171122094447

0 Likes

#2

@baskren,
Thanks for reaching out. Not sure I’ve ever seen Brave stop other applications from functioning properly. I’ll have to reach out to some team members for additional input.

Did you have Brave installed initially first or did you have the other apps installed and the installing Brave seemed to break them? And just to confirm, this happens whether or not you have any Brave instances open, correct? Simply having it installed causes the issue(s)?

0 Likes

#3

I had the other apps installed first and didn’t notice the issues until after a reboot. Yes, it happened even if there was not a Brave instance running (or at least the UI) - which makes it doubly strange.

I would really hate to be the dev assigned to this.

1 Like

#4

@baskren,
Can you try launching Brave and disabling Hardware Acceleration? You’ll find it in:
Settings --> Advanced --> System --> Hardware Acceleration.
You can also do this with the --disable-gpu flag by launching Brave from the terminal with the flag appended at the end.

Let me know if this resolves the issue.

1 Like