Brave won't shut down fully, and therefore cannot relaunch

Description of the issue:
Lately Brave does not shut down completely, despite appearing to do so. There are always at least two processes which need to be killed in the task manager. As a result, until all processes are killed in the task manager, a new session of Brave cannot be launched.

As an added inconvenience, killing the processes with RAM using RAM via the task manager wipes the session memory (i.e. you can not restore previous session or even see which tabs were open). See also: Restore session broken by apparent memory leak

How can this issue be reproduced?

  1. Launch Brave
  2. Close Brave
  3. Launch Brave again before all processes have shut down (the more memory is cached, the slower the processes shut down …if they ever do at all, that is)

Expected result:
Being able to close and relaunch Brave the way I used to, the same way I can any other application

Brave Version( check About Brave):
Version 1.15.72 Chromium: 86.0.4240.75 (Official Build) (64-bit)

Additional Information:

1 Like

Hello @Go-go_duck

go to brave://settings/system
try to disable Use hardware acceleration when available

and

could you disable Continue running background apps when Brave is closed

hope that help and have a nice day :slight_smile:

2 Likes

Hey thanks @justsomeone1

Good suggestion, but no dice I’m afraid. “Continue running background apps when Brave is closed” was already disabled, and disabling hardware acceleration does not seemed to have fixed the issue.

An interesting development while trying to update to the new version though:

you welcome

could you restart you device and see if the update work

and check if the update fix it and have a nice day

1 Like

:+1: Thanks again
After rebooting the update installed successfully.

Sadly the issue also persists in the new version of Brave.

You also have a great weekend :slight_smile:

you welcome

could you disable all extention then restart your device then check if it run fine or not and thanks a lot

1 Like

.
.
I notice you’re missing some Brave processes … did you disable those?

image

nice spot @caldercay

but he said

Appears Chrome users are seeing the same issue.

Bug:
Issue 337996: Chrome.exe still running in background. Chrome will not relaunch upon closing


… that was opened in 2014 and it’s still open !!
.
Anyway … @Go-go_duck … do you feel comfortable to navigate your file system and edit a file in the Brave configuration folder? We will edit (using Notepad) a file and see if that fixes your issue. Let us know
1 Like

Bingo! The extension to blame was Malwarebytes Browser Guard.

1 Like

glad to know that you figured it out and have a nice day

1 Like

You too :slight_smile: And thank you both for the help!

1 Like

thanks and you welcome :slight_smile: