Brave won't keep me logged in


Description of the issue: Brave will not keep me logged in to sites after I restart it. Last week I (temporarily) set the “On Exit” settings to clear Browsing History, Download History, Cookies and other site data, and Cached images and files. I restarted Brave twice, then went back in and turned all of those “On Exit” settings back off. However, now Brave will not automatically log me into sites (Gmail, Reddit, Fox News, etc) when I restart it. It’s like the “On Exit” settings are still enabled, but in the GUI, they show to be disabled.

How can this issue be reproduced?

  1. Login to gmail
  2. Close and re-open Brave
  3. Gmail requires me to login again

Expected result:
I should be logged-in to Gmail when I open the page.

Brave Version( check About Brave):
Version 1.60.110 Chromium: 119.0.6045.105 (Official Build) (64-bit)
on WIndows 10 22H2

Additional Information:
Is there any backdoor way to double-check that the “On Exit” settings are turned off? ie - something in the Flags stuff?

Digging a little further, I saw that I had at some point disabled “Sign in automatically” in Password-manager settings. I just now re-enabled that and restarted Brave, but it still won’t automatically log me in to sites. I’ve restarted Brave a few more times, but it still won’t log me in.

Finally found the last problem - under “Cookies and other site data”, I had enabled “Clear cookies and site data when you close all windows”. I turned that off, and the problem went away and sites stay logged-in after Brave restarts.

So, for future reference, there are (at least) three places this can bite a user:

  1. Under “Clear Browsing data” → “On exit”
  2. Under “Password manager” → “Settings”
  3. Under “Cookies and other site data”

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.