Brave wont change back to integrated GPU and high battery usage

macos
#1

Hello,

I have a problem with GPU usage in macos Mojave.

Description of the issue:

When a webpage activates the dedicated GPU it will never go back to the integrated GPU when the webpage is closed. This then reflects in a much higher battery usage. I checked on chrome using the same webpages to trigger the dedicated GPU, and when I close them, always revert automatically to the integrated.

**Steps to Reproduce (add as many as necessary):

  1. open a webpage that activates dedicated GPU, like agar.io.
  2. GPU will change to dedicated (Radeon 555x)
  3. lose webpage tab
  4. Brave continue to use dedicated GPU and will never change to integrated GPU
  5. open brave task manager and kill GPU process
  6. GPU will change to integrated until the dedicated is activated and then is fixed again

Actual Result (gifs and screenshots are welcome!):
The result is a much higher battery usage because of the unnecessary use of a dedicated GPU

Expected result:

To Brave automaticly switch back to integrated GPU

Reproduces how often:
Allways

Brave Version(See the About Brave page in the main menu):
Versión 0.60.47 Chromium: 72.0.3626.119 (Build oficial) (64 bits)
ALso tried beta version. Same result

Reproducible on current live release (yes/no):
yes

Additional Information:
Macbook pro late 2018. Mojave 10.14.3
Chrome last version behave properly

Thank you

0 Likes

#2

Signed up here to report the same issue! Loving Brave so far, but this is quite frustrating. Chrome correctly reverts back to integrated graphics, whereas Brave continues to use the dedicated GPU when leaving a site that triggers the change.

Installing gfxCardStatus shows “Brave Browser Helper” as the culprit.

0 Likes

#3

@nikles,
There is an option to disable GPU acceleration in settings:

Settings --> Advanced --> System --> Hardware Acceleration
I’m not sure what you’re using it for but by disabling it you should bypass the issue you’re encountering. It’s not ideal but let me know if it works. If it does I can discuss more ideal solutions with the dev team.

1 Like

#4

Having the same problem on my MacBook Pro late 2016 Mojave 10.14.3. This bypass the issue. With disabled Hardware Acceleration it doesn’t switch to discrete graphics at all. Since it is just a bypass, it is not a real solution for graphic intensive work.

0 Likes

#5

Same, I’m able to disable hardware acceleration totally via the Settings screen. Ideally Brave would be able to detect when the tab that caused the switch to the GPU is closed, and switch back in the same way Chrome does.

0 Likes

closed #6

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes

opened #7
0 Likes