Brave with VPN doesn't load

Description of the issue:
When I enable VPN on my mac, the websites on brave don’t load! But they do load on Safari. The VPN is a 3rd party.

How can this issue be reproduced?

  1. Enable Windscribe VPN
  2. Open Brave
  3. Go to any website

Expected result:
The website should load!!!
Brave Version( check About Brave):
Additional Information:

To confirm, can you tell me if you’re using the Windscribe VPN extension, or are you using the downloaded application on yoru mac?

Windscribe app so I can use it with any app

On my end, I downloaded/installed Windscribe and am able to browse normally while connected to the VPN. Also using macOS.

Can you try creating a new temporary profile and use it to test and see if you get the same results with a fresh browser profile? Make sure that after creating the new profile, you close the window with your original profile open in it.

Yes, with my profile “test”, I still get the same result.

I do not see Windscribe running in the screenshot you sent. Do you have any specific configurations for Windscribe, or are you more or less using the default setup?

It’s on top on the menu bar. I just hid the app in the dock.

1 Like

:point_up: And for this? Also, do you get different results with the Firewall turned off?

Yeah same result bc “the firewall disables all internet connectivity if you are not connected to our network”. So it doesn’t afftect when I’m connected.
And yes, I kept more or less the default settings.

When enabling windscribe vpn, do other browsers also have the same issue?

1 Like

No, I said Safari doesn’t have this issue. I’ve been using Safari + Windscribe for at least 5 years.
And no problem with Opera too.

Just using the app (extension installed, but not used)

Tested with cnet and checking my ip so far.

I resetted the flags : no success.
Then the settings : no success.
Finally, I reinstalled Brave : no success.

Ok, I tried with Proton VPN which did worked on Brave!

Is there a way to completely uninstall Brave? Because when I do it with AppCleaner, Brave restores my profile with everything after reinstallation.

Guys, I got it working with VPN. Not sure how, but I think it’s because I resetted Lulu & Windscribe & did some reboot. Still don’t know how this affected Brave only in combination with Windscribe. :smiley:

I’m glad that you got that figured out. For the record, when you go to uninstall Brave, you should be prompted during the Add/Remove programs to remove your Brave browsing information along with it.