Brave with Tor not connecting

Started right after the most recent update.

1 Like

@Passenger Could you provide some more details?

  • Which version of Windows?

  • Which version of Brave?

  • Is an error being shown or what happens?

I’m asking as I just tested. Initially it showed Disconnected but then it automatically went through the process, to where I had:

So it’s just good to know if you’re seeing anything in particular.

Windows 10 Home 64-bit, 22H2, build 19045.2965

Brave v1.51.114

No error as such, just that it is disconnected and stays that way.

Okay, thanks. Guess let me also ask if you tried the default troubleshooting mentioned at which I’ll copy/paste below:

  • Toggle Tor settings: In Brave, go to Settings --> Privacy and Security --> Tor windows and toggle the Private window with Tor option off then on again. Doing this will disable Tor and delete the (current) Tor directory on your machine. Switching it back on will re-enable Tor functionality and generate a fresh Tor directory.
  • Check network admin settings: It is possible that your network admin is blocking Tor access. Check with your network administrator or, if you are the admin, check your network settings to see if access to the tor network is blocked. You can also test to see if this is the case by visiting the official Tor website, as most networks blocking Tor access will also block access to their site.

Did the troubleshooting just now, and no change.

I’m pretty sure it’s not the network connection because the Tor browser (based on Firefox) is working OK.

@Passenger Understood. But at the same time, my browser is connecting. There should be nothing from extensions causing it, as extensions don’t run on it by default. Same process should go to the idea of cookies, as I believe it should be starting fresh and deleting afterward.

That said, you could try one of the basic troubleshooting we use on other things. I doubt it will make a difference, but if you create a new profile and then try to use Private with Tor, would it work? If so, at least would let us know it might be a profile thing.

I’d ask if VPN, Firewall, Internet Security/Antivirus, etc might play a part, but instinct tells me it’s unlikely.

Guess just advise if you do try with new profile. Otherwise will just have to hope for ideas from @Mattches tomorrow, unless maybe @JimB1 or @CerealLover might have some ideas on other things to look at.


Welcome back @Passenger , been a while.

Nothing immediately strikes me here that hasn’t already been tried; I’d be interested in seeing what you have in brave://version (feel free to redact things if need be). Also does it perform any of the connection steps or none at all? And if it does, is the final state informative in any way, where a screenshot might help?

1 Like

Great support here guys — came here t ask/say that I am also interested in whether or not it even attempts to connect or not.

Nothing? No one else with same problem?

@Passenger nobody else been reporting it. Can’t replicate it either. I do know we had asked for information. Like JimB1 asked you for information shared on brave://version if you felt comfortable sharing.

I also know I asked you about new profile, but you didn’t respond about that yet.

Then Mattches had asked if you see it attempting to connect at all or if it just stays on disconnected?

I completely uninstalled and reinstalled Brave.

OK. So are you saying it’s working now? Or not?

If not – still none of the questions above has been answered.

It is still not working.

OK. Well let us know about the other stuff.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.