Brave will not open chase.com

bug

#21

strange but i am kinda facing this too, keeps on loading!
shelby


https://discord.software/ https://adobereader.onl/ https://itunes.red/


#22

The latest update seems to have solved the problem. As @krellan has suggested above tweak the shield for www.chase.com (see below for specifics) and after that open a new window to hit www.chase.com.

I played with a few shield settings and found that after I disabled Fingerprinting protection to Allow all fingerprinting then it “worked”. It wasn’t smooth, first time it did nothing but then next time around it got to a page where it prompted me for 2FA and so far looks like no functionality is broken (but I haven’t done exhaustive testing).

Here’s what the site shield settings look now.

The version that I’m using is:


#23

Thanks to @krellan and @Ts43e8QEqv since these solutions worked for me just now. Turning the shield completely off worked the first time I tried it, but I didn’t want that as a permanent solution. Allowing fingerprinting on this site but leaving the rest in place also worked liked a charm.