Brave will not open chase.com

bug

#1

Chase.com will not load while using Brave. It loads with Safari. All other sites seem to load fine.
I have iOS El Capitan 10.11.6
Brave version is 0.22.13

The page begins but stops loading right away. No items are clickable. Circles spin, eventually times out with a frown face.

Thanks.


Brave does not load www.Chase.com
#2

Hi @inspector99,

Try going to chase.com turning the shields completely off, but then open chase.com in a new tab. That works for me whereas if I try to turn off shield components while already on chase.com it hangs for me.

Cheers.


#3

I have an account with chase as well. what exactly are you entering as a URL? The problem may be in how you have your shield configured. Try turning it off after you enter the url and see if you can then bring up the bank website. They require that you accept cookies.

mobear410


#4

Hmm… oddly today my recommendation above doesn’t solve the job anymore. Turning off shields completely allows one to access the login and start the process of getting in but after moving through 2FA I also get an error:

Please turn on JavaScriptTM in your browser
It looks like your web browser isn’t using JavaScriptTM. Without it, some pages won’t work properly. Please change the settings in your browser to turn on JavaScriptTM. You can search “how to turn on JavaScript” in your search engine for your browser’s specific instructions.
See which browsers work best with our site.


#5

Thanks, the shield did the trick. Had to open a new tab after dropping shield, the the site loaded no problem.


#6

Great! Let me know if it reverts back to an issue.


#7

Chase site is still not working for me. I’ve tried the workaround for dropping shields on the first page, then opening the same page again. Also, many variations. All attempts end at the message that javascript is not enabled. Firefox will be my own workaround for the duration, but I am greatly enjoying Brave in general.

Brave 0.22.667
V8 6.6.346.24
rev 0433b26
Muon 5.2.6
OS Release 10.0.16299
Update Channel Release
OS Architecture x64
OS Platform Microsoft Windows
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 66.0.3359.117

#8

That happened to me also. It’s not the crash bug, that’s different: https://github.com/brave/browser-laptop/issues/13947

In this case, Brave does not crash, but instead, just hangs the browser tab and becomes unresponsive. The overall Brave user interface still works, but nothing in the tab works.

I had the Shields enabled (Brave lion icon is orange), then opened https://www.chase.com/ in a new tab. I get really sluggish response, and high CPU usage. The Chase website fails to load completely, it still displays spinning arrow graphics from Chase.

The workaround is to turn off Shields in that tab, then open another new tab, and try https://www.chase.com/ again in that new tab. Attempting to re-use the existing tab, that was trying to load Chase, appears broken: clicking the Stop button does nothing, and the address bar becomes unresponsive.

I’m running Brave version 0.22.667 on MacOS.

Josh


#9

+1

I now get the chase recommendation to use a “compatible browser.” Well chase, how about I choose a compatible bank!


#10

I’ve actually had some success by letting the active page time out / crash / present a frowning face of doom (or whatever it’s officially called). I can then turn off the Shield which will force the page to reload within the existing tab without issue. The process is time consuming, but I was able to repeat my success a few times. Could someone else give it a whirl to confirm or deny if I’m an outlier or the norm? Does anyone have any clue as to if or when this might be addressed (or what the root cause might be?)?

-K
Brave V. 0.22.669


#11

I’m having the same issue. I get nothing but Chase’s blank blue home page with a spinning gray pinwheel. That happens both if I try to connect to Chase directly or to log in to my account through Last Pass. Since I don’t have that issue with Safari (I’m using macOS High Sierra on an iMac), Firefox, Chrome, or Opera, the issue must be with something happening on Brave. I’ve tried all the above suggestions (turning off all shields, disabling java) and still get nothing. Clearly an issue that will need to be fixed by Brave’s tech team/programers.


#12

atlienk…I attempted and failed using your workaround. My situation remains as before.


#13

Looks like Brave 0.22.721 didn’t solve the issue. I’ve now resorted to using other browsers for accessing https://www.chase.com/. Anyone else having encountering new / different results?


#14

Checked Chase.com again just now…same results as atlienk with…

Brave 0.22.721
V8 6.6.346.32
rev bfe7cdd
Muon 6.0.12
OS Release 10.0.17134
Update Channel Release
OS Architecture x64
OS Platform Microsoft Windows
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 66.0.3359.170

#15

No longer an issue. Don’t know what changed but it works now to chase.com on Brave browser.


#16

What version of the browser are you running? I actually got an update last night / this morning and still have the same results.

Brave: 0.22.727
V8: 6.6.346.32
rev: 2c94bbad00d70b87328f04574725979960e18f9f
Muon: 6.0.12
OS Release: 17.6.0
Update Channel: Release
OS Architecture: x64
OS Platform: macOS
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 66.0.3359.170


#17

Just retried after update…Chase.com now allows logon for me as well…

Brave 0.22.810
V8 6.7.288.43
rev 8f30eeb
Muon 7.0.6
OS Release 10.0.17134
Update Channel Release
OS Architecture x64
OS Platform Microsoft Windows
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 67.0.3396.71

#18

That’s so odd.

I’m now on the 0.23.19 release for both Mac and Windows and still don’t have any success unless I disable all shields.

With that being said, I do seem to get more of the chase.com page itself to load but the login prompts still never appear and the page ultimately crashes if shields are enabled.


#19

Anyone had any success with getting this to work? I know that we’re a few versions down the road now and I still can’t get it to work as hoped. Am I the only one who’s still having the issue?


#20

I see the same problem: Visiting https://www.chase.com/ doesn’t work. Page never finishes loading, shows a lot of spinners embedded on the page. www.chase.com works fine with Chromium.

A few variations I tried:

  • Initially had shields on default which blocked 3rd party cookies

  • Tried shields on “allow all cookies”. (New tab. Load page from scratch.) Same problem.

  • Then added “allow ads & tracking” to shields. (New lab. Load page from scratch.) More of the page loads & displays, but ultimately the same problem (never finishes loading; I see lots of spinners).

  • Then added “allow all fingerprinting” to shields. (New tab. Load from scratch.) Appears to work.

FWIW, my guess is that Chase.com has created a fragile page that requires browser fingerprinting (a practice that rubs my sense of ethics the wrong way). So it’s not really Brave’s fault.

Brave: 0.23.77
V8: 6.8.275.24
rev: 0125b5f5ddc7eebc832ceeb4f4275230ec49d149
Muon: 8.0.6
OS Release: 4.15.0-30-generic
Update Channel: Release
OS Architecture: x64
OS Platform: Linux
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 68.0.3440.84