Brave wallet verify wallet button broken on android


Description of the issue:
When I click on the “verify wallet” button within the brave rewards pulldown, the button turns blue, but does not actually do anything (worked fine on desktop)

How can this issue be reproduced?

  1. Open brave widget
    2.push “verify wallet” button
  2. No response beyond change in colour

Expected result:
Expect result is to link the wallet to my existing uphold account. To open a new tab, or ask to sign in, or something.

Brave Version( check About Brave):
Brave 1.21.77 chromium 89.0.4389.90

Mobile Device details
Android valaxy tab S3
SM T820

Additional Information:
It looks to me like a visual programing error where you have two buttons (button shape and text) overtop of each other, but the top one is not the one with the link and was intended to be underneath the text button, for effect.

I have the same issue.
Brave Version:
Brave 1.21.77 chromium 89.0.4389.90

Mobile Device details
Android 8.0.0
Galaxy S7 - SM-G930F

1 Like

Have y’all found out a way to log in via the mobile app.

No, nothing so far. And I updated it to the last version of April too.
Brave 1.22.71, Chromium 89.0.4389.114

Hi @mneilgri, @siriusng2 and @Gil1084a , have you checked if your Android can pass a SafetyNet Test?

I’m not really sure I know what that is, but I found a couple apps that supposedly check it and the results were:




Not really sure if that’s what you asked for

No, that’s good, @siriusng2, it doesn’t seem to be a problem for you.

Have either of you checked to make sure your region/ country is **supported by Uphold?
https://support.uphold.com/hc/en-us/articles/360026786712-Non-Supported-Geographies-?mobile_site=true
I believe New York has some issue, too, but I’m not sure at this time…

Edit: I’m not 100% sure if **this matters or not for Android when claiming, @siriusng2

@mneilgri is a Creator, so it’s a little different for them. I think Creators also don’t start receiving payout til about a week after non-Creators. @mneilgri, if Support doesn’t reply to your topic this week, I would make a new one under


to be better seen - or if you have a current DM thread with Support, just edit/ bump that one versus making a new as it could get buried.

1 Like

Concerning the Uphold support in my country, I’m confident it is, as I have a verified account that I can use with Brave for Windows, and Brazil is not in that list of non-supported countries, so I don’t think it would really matter whether that affects me claiming or not.

Thanks for the tip to make a new topic/bump an old one. Will do that if support doesn’t reply here.

2 Likes

Payout is currently processing, too. This was posted yesterday:

Have a read through it, check your setup is all right, and just wait a bit - it can take up to several days to process all. Support should post any updates to it, too.
If your problem persists after processing has ended (when the icon changes to red, I believe), you can follow the instructions about contacting Support in the second half of that post.

*So, I think trying to interact with any kind of claiming/ connecting, is best left to wait til this process completes first.

1 Like

Sorry for the late reply. I passed a safetynet test, so that’s not it. I’m in Canada, so region shouldnt be an issue. Furthermore, I have no issue on my desktop, only my tablet. And I’m able to log in to uphold directly, just not able to verrify my tablet brave wallet. Hitting the verify button simply has no effect

Hi, @mneilgri, no worries :slight_smile:

It seems very likely, and unfortunately, that you’re being affected by a known issue with BAT not porting to Uphold. Support has been working to fix this, but no news yet. You can monitor for any updates on it here:

You could try the fix in the first post on that thread (with the latest version, of course), it has worked for some… :crossed_fingers: