Brave wallet not allowing 0 GAS Price on Arbitrum Test Network

I have set up Reddit’s arbitrum testnet successfully by following the below instructions. I am able to see the MOONS I have transferred to my wallet as well.

But I am not able to send the MOON token back to my Reddit vault as Brave Wallet is not allowing me to set the GAS price as 0. Refer to the below screenshot. Apparently, Metamask allows the user to do this.

My tokens are now stuck on Reddit’s arbitrum testnet as there are no faucets available as well. Appreciate your help if you have a solution.


I’m not very familiar with Arbitrum but wouldn’t the transaction never get picked up with 0 gas?

It’s an Arbitrum Test network. So I don’t think it needs fees to be picked up.

Could you try again on yesterday’s hotfix? V1.32.115

Sorry just a correction that 0 gas is not yet supported but we’ll allow it with a warning.

1 Like

Ok thanks for the update @brian ! Do let me know which build it is targeted for. More than happy to test it out in Production for you :slight_smile:

Being tracked here:

Hi @brian the brave wallet is allowing me to select 0 fees now. However, when I try to make a transfer I keep getting an error. Refer to the below screenshot. Is there any way to check what the error is?

I am currently using
Version 1.33.106 Chromium: 96.0.4664.110 (Official Build) (64-bit)

Please try again as the fix is in 1.34.80 which was just released.

Hi @brian Thanks for your reply! I have updated my browser to the 1.34.80 version.

I am able to proceed with selecting 0 GAS fees now, but when I approve the transaction it shows an error in the status. Can you let me know where I see the logs to get more details on the error?

Refer to the below screen recording for the steps I performing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Could you go to edit your Arbitrum network here:

I bridged some funds to Arbitrum and then added it via but I noticed that the first networks (Brave always uses the first one) were${INFURA_API_KEY}${ALCHEMY_API_KEY}

It does list some other networks though.

Could you try using one of the other ones? I’ll work on using a fallback URL when the first ones are not correct.

This network seems to work if you want to put it first for now:

I am not sure it’s possible to have transactions paying zero ArbGas price, on testnet or otherwise. When I tried to broadcast such a transaction, the Arbitrum node returned the error - gas price too low.

For comparison, Metamask is showing the same error.

Reading the docs, I found this explanation:

On Ethereum, the gas price paid by a transaction is equal to its gasbid. Arbitrum, by contrast, treats the gasbid as the maximum amount the transaction is willing to pay for gas. The actual price paid is equal to the current Arbitrum ArbGas price, whatever that is, as long as it is less than or equal to the transaction’s gasbid. If the transaction’s gasbid is less than the current Arbitrum gas price, the transaction is dropped and a transaction receipt issued, saying that the transaction’s gasbid was too low.

You mentioned that your Reddit tokens are stuck on Arbitrum testnet. If it’s still the case, I’m happy to send you some ARETH to let you to move your funds out. Alternatively, you can bridge Ropsten Ether to Arbitrum using this bridge.

Going to mark my answer as solution, but if you need further help feel free to reply here.