Brave Wallet "Network request failed" after PW input, and then zero balance

Description of the issue:
Hello!
I’m assuming this is a server issue, but when I input my password I get a “Network request failed” notification. If I try to recover by seed, I get a white flash when I hit submit and the page does not change. If I then close and reopen the extension, it shows my correct account but with a zero balance. My password is correct because I once I’ve entered the extension after closing, I can use it to view my seed phrase. Am I doing something wrong or is this a Brave issue?

Steps to Reproduce (add as many as necessary):
1.
Launch Brave
2. Open Crypto Wallet and input password, get Network request failed
3. Click “Restore account” and input seed to get only an instant white flash, and then nothing changed.
4. Close extension and reopen it. Now the correct account is logged in without a password, with an incorrect balance (and no BAT).

Actual Result (gifs and screenshots are welcome!):

Expected Result:
I should see my correct balance, and my password should work. This is my balance:

Reproduces how often:
Always

Brave Version(See the About Brave page in the main menu):
Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes

Additional information:
I’m using Windows and also have Metamask extension for Brave.

Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.