Brave wallet can't connect to uphold FEB 22

With the update my uphold account cannot reauthorized. This resulted in at least .7 BAT being lost for February’s estimated rewards and I still have not received my 1.8 (estimated) for January’s BAT. The process went as follows: press triangle for rewards > verify wallet > continue > uphold > continue to login > at this point uphold opens asking for permission to reauthorize after pressing > “Something went wrong. Please try again later”.

What I tried: logging in an out of uphold and clearing cache for the brave app/uphold. Reinstalling Brave (yes I realize this is probably how February’s accumulated awards were dropped) and uphold and trying again. This yielded the same result.

Information about my account/device:
My brave wallet was verified. My device is a Moto G Power 2021 CPU: Snapdragon 662 RAM:3GB, 4GB
Storage: 32GB, 64GB. Android 11.

1 Like

Same issue for me also

I also have the same issue

My BAT was deposited to my Uphold wallet. My Brave browser however will not connect to the uphold wallet. Whenever I try to connect I still receive the message that something went wrong in Uphold.

Final update:

Upon trying to reauthorize my uphold account I was met with the same message but my browser opened up a web page that allowed me to authorize by logging into my uphold account. I’m happy to say my issues are resolved. A big thank you to whoever has been working on this!

I removed the Uphold app. The error was coming from it when I would try to reverify my wallet. But when it fails, the process takes you from the browser to the uphold app and then that is where the error comes from. By removing the app from my Android phone, it kept the process in the browser and worked for me. This is kind of silly since I have the app installed for a reason and want to use it. I should not be tied to having to do everything in the web browser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.