Brave VPN disabled Wi-Fi when another VPN process exists - iOS

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Whenever I enable the brave vpn while on Wi-Fi, the vpn will not enable and also kicks me off the Wi-Fi. I have tried deleting app, removing the vpn configuration, and resetting it through the app none have worked. I pay for the subscription.

How can this issue be reproduced?

1.can be reproduced by enabling vpn through app.
2.
3.

My expected result is to be able to use the vpn since I pay for it:

Brave Version(1.40):

**IPhone 12 pro with lates iOS **

Additional Information:

@willblais

Notice Brave Support team member @Michal - his replies.

Hi, I have tried all of the things stated in this email. Any other solutions?

Exactly when and where - might you provide screenshot(s)?

For examples:

  • the toggle switch will not slide back and forth
  • the toggle switch works, but no connection to Internet

Also, maybe ‘Private Browsing Only’ setting needs to be Enabled

Still does not work, as you can see it is still spinning and won’t actually enable. You can also see that there is no Wi-Fi. In the vpn picture I have to turn the connect on demand slider off to actually connect to Wi-Fi again.


@willblais

In Brave Browser for iOS Settings

  • Disable: Brave Firewall + VPN
  • Enable: Private Browsing Only

In iOS Settings

  • Disable: Connect On Demand (General > VPN)
  • Disable: Wi-Fi
  • Disable: Bluetooth
  • Disable: Cellular Data

Double-check all of those Settings, starting with the Brave Settings, ending with the iOS Settings.

Now, you might test, by:

  • Enable: Wi-Fi
  • Enable: Brave Firewall + VPN

If that fails, then:

In iOS Settings, go to: General > VPN

Delete the VPN configuration.

While still at the iOS Settings: General

Scroll down to Shut Down and shut down your iPhone.

Wait at least 30 seconds.

Start up your iPhone.

In iOS Settings

  • Enable: Wi-Fi

In Brave Browser for iOS Settings

  • Enable: Brave Firewall + VPN

A new VPN configuration should be created. When ready, verify by visiting the iOS > General > VPN settings.

IF no VPN connection, then:

Clear as much of the Private Data in Brave Browser, as you can/may.

Delete Brave Browser for iOS.

Go to iOS Settings: General

Scroll down to Shut Down and shut down your iPhone.

Wait at least 30 seconds.

Start up your iPhone.

Download Brave Browser for iOS, from the App Store.

Install Brave Browser for iOS.

Hi, I followed all the steps you have me. It didn’t work and it’s still doing the same thing.

@willblais

Worth a look:

https://www.hexnode.com/forums/topic/unable-to-change-user-account-password-on-mac/

EXCERPT:

The Screen Time settings will be shared across all your Apple devices if you’ve signed in using the same Apple ID, and ‘Share Across Devices’ is enabled on any device signed in to iCloud.

Try, on your iPhone . . .

Sign Out from iCloud

Disable Brave Sync

Then:

  • Disable: Brave Firewall + VPN
  • Disable: Wi-Fi

Then:

  • Enable: Brave Firewall + VPN

Does that cause a prompt for you to Enable: Wi-Fi ?

No luck, I also wanted to state that the vpn has the same issue over cellular as well as Wi-Fi

@Michal , @Shznakl (Guardian Team)

@willblais has tried several changes to settings with no success. Brave Firewall + VPN will not connect over:

  • Cellular Data
  • Wi-Fi

on iPhone 12 Pro; Brave Browser for iOS v1.40

It might be a legitimate bug. Only brave vpn team will be able to help after changing some stuff in their own code.

@willblais what you’re experiencing is referred to by us as the “WiFi bug”. It shows in various different ways, yours appears to be quite persistent and annoying. It is a bug on Apple’s side that we can’t directly control and it is a little weird to resolve.

To start, do you also experience the same problem over your cellular connection? To test start by disabling the VPN, disabling WiFi, enabling the VPN. Does it then route internet traffic?
A good way to detect this bug is actually shown in your screenshots here. The VPN appears to be connected, but your device does not show an IP address, in the case of our servers starting with 10.xxx.xxx.xxx. Without a “virtual” IP address no traffic can be routed

In case you have more questions please feel free to open a support ticket from the VPN settings within Brave

Best

CJ

1 Like

@willblais
For clarification on our end I have two more questions for you:
Did you ever try to reset the configuration from the Brave → VPN settings interface and did that change anything?
In the iOS Settings → General → VPN interface (the overview interface to see all VPN profiles) did the slider to enable/disable the VPN connection ever flicker back and forth rapidly or was it always set to connected after trying to initiate the connection in the Brave app?

This information will help us classify this bug a lot

Thanks

I did try to reset the configuration in brave, the slider does flicker from on back to off when I try to enable it from the iOS vpn section

Hi @willblais

Did you try the steps to enable the VPN tunnel from the cellular connection yet? We are curious about the outcome of that.
Please also try to reset the configuration prior to trying those steps

To start, do you also experience the same problem over your cellular connection? To test start by disabling the VPN, disabling WiFi, enabling the VPN. Does it then route internet traffic?

Best

CJ

It does not work. When I enabled it the VPN just swirled like it was loading but it’ll do that indefinitely.

@willblais
Ok that is very frustrating. I am sorry that you are encountering this bug. May I ask you to reset the config once more and then navigate into iOS Settings → General → VPN → tap on the (i) next to the Brave VPN profile and from there delete the profile. After you have done that please force restart your device.

This may seem redundant in various ways and very annoying but unfortunately we have no reliable way to resolve this bug. The issue could be fixed by taking various steps, some customers don’t have to do all of them, some do. It is completely unpredictable from our side and very difficult to provide support for.
I apologize for the terrible experience

Best Regards

CJ

I have just solved the issue, I deleted an existing vpn from another app that was not enabled and had the connect on demand slider off. Once brave vpn was the only configuration on my phone the vpn worked again.

I appreciate all of the help and I hope my solution can help anyone else that struggled with this problem.

2 Likes

@willblais

Please change your issue topic title, in order to much more accurately reflect the actual issue and result.

FROM: Vpn removes me from Wi-Fi and won’t connect

TO: Brave VPN disabled Wi-Fi when another VPN process exists - iOS

Thank you.