Brave / Uphold not reauthorizing after update

I currently have Brave on my desktop pc and mobile. Both are linked to 1 uphold account. I have received my january rewards from my desktop, but not my mobile.

Typically it doesnt take this long so i did some troubleshooting and realized i needed to update the phone brave app.

After updating i attempted to reauthorize my uphold account, but it continually says “something went wrong” after trying. Anyone else having trouble reauthorizing after updating the brave app?

What Operating System and Brave version are you using (Menu --> About Brave)?
Android 11 / Brave 1.35.100

*Is your browser wallet currently verified?
It was before i attempting logging out and logging back in since reauthorizing wasnt working.

What date did you verify your wallet?
Months ago

Have you been able to successfully receive payments in the past?
Yes, myltiple payments in a row have worked

Are you using a VPN? (yes/no)

Are you in a supported region (see here for list of supported regions)?

Does your device pass the SafteyNet check (Android only)?

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??

1 Like

UPDATE / Possible solution:

I was thinking maybe the issue was that the authorization was being done through the uphold app, I decided to uninstall it and try authorizing through the browser. It worked. Uphold is successfully authorized now, and the brave payout window still shows that my january rewards are on the way.

Feeling optomistic. Hoping it goes through now!


That’s exactly what i did too, just waiting for the mobile payout!

Update #2:

Although i fixed the uphold connection issue, it no longer says my rewards are on the way and they have not been deposited. Feeling much less optomistic

Just followers your steps and its worked thank you​:muscle::muscle:

1 Like

I’m facing the same issue now. And I have also tried the way its mentioned here. But didn’t work for me. Could you let me is it necessary to delete the brave and uphold as well. I could see both app are up to date.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.