Brave + Uphold keeps logging me out + maintenance page

Briefly describe your issue:
Its been a couple of months since this issue started happening. Every time i try to loggin to my Uphold account in Brave it inmediately get logged out and i get an Uphold maintenance page when try to loggin again.

That maintainance page stays there for a few days until it allows me to logging again. But then, i got logged out and the maintainance page is there for a few days again. This is been a loop for the last couple of months.

I keept in the loop some of the guys on discod (Bauzz, Griff) but still the issue persists so i decided to create this post here.

What Operating System and Brave version are you using (Menu --> About Brave)?
Latest version i have is 1.62.165

Is your Brave Rewards Profile currently verified? (yes/no)
Yes

What date did you connect a your Brave Rewards Profile?
It was a long time ago, around early 2021. I been getting my rewards but just this issue started happening a few months ago.

Have you been able to successfully receive payments in the past?
Yes

Are you using a VPN? (yes/no)
No

Are you in a supported region (see here for list of supported regions)?
Yes, im in South America - Uruguay

Does your device pass the SafteyNet check (Android only)?
Yes

Have you fully completed Uphold’s CDD requirements?
Yes

@Sagymaista if you go to uphold.com are you able to login with no issues or do you experience this same issue? In other words, trying to find out if you’re only getting this message when trying to connect to Brave or if it will happen even just visiting the site.

If going directly to the website results in this message, I want you to also test the following:

  • Open private window and attempt to login

  • Try going to Uphold in Chrome, does it give the same message?

1 Like

Hi @Saoiray ,

I get the same message trying to logging from incognito mode in private window.

I tried other browser aswell (Safari) and i get the same mantainance page from Uphold.com. Super weird because https://status.uphold.com seems up and running.

From my phone Brave browser i can access the login page on uphold without problems. Not sure whats going on :thinking:

Yeah, so something weird going on there.

Might be that it’s loading on mobile version of the site but an issue with the desktop version. Not sure if perhaps it’s just for your region/language, or what?

You’ll likely need to contact Uphold about it. You can do that via email at [email protected]

1 Like

I just submit a ticket to them aswell. Lets see how it goes.

Thanks Saoiray! Ill update here after i get a response from uphold.

Sounds good. Btw, not sure what you said, but I’ll prep you now. If you told them you’re having an issue while trying to login through Brave, they likely are going to disregard anything else you say and will try to send you back here for support.

If they do that, make sure to stress it happens on multiple browsers and it’s not a Brave issue. Try to force the idea that it’s a phone vs desktop issue from what you can see. Hopefully upon clarification, they’ll get it passed to the right teams.

It’s messed up, but just is a little something I’ve realized over time. Hopefully they won’t be that dumb, but wanted it out there so you don’t get confused or anything if they do send you back this way. Their support just can be lazy is all, lol.

@Sagymaista did you ever get any updates?

Yes.

The issue is that i use a VPN for my work. When i have that on, Brave logges me out of Uphold and this issue happen until i turn the VPN off.

So it was kind of my bad (?)

Thanks for the support though!

1 Like

Me pasa algo similar, abro brave y se cierra al momento, que puedo hacer ?

Brave o te deslogea de la wallet de uphold?

Brave , abro el navegador y rápido desaparece

No me parece que sea el mismo issue que tenia yo.