Brave unusable with DuckDuckGo Privacy Essentials

Description of the issue:
The DuckDuckGo Privacy Essentials (DDGPE) browser extension causes several major problems in Brave.

Firstly, any keyboard input (e.g. typing, hotkeys) while on a non-Tor private window, results in the Brave browser crashing and closing all windows (both private, regular and Tor). This only happens in non-Tor private windows, and only when DDGPE is enabled, but also every time DDGPE (and otherwise nothing except Brave Shields) is enabled.

I am including the graphical example from @AX3M for demonstration purposes:

Secondly, even before this first problem was introduced (some time between Brave versions 63 and 65), DDGPE was already making it impossible to search from the address bar while in a non-Tor private window. This is because DDGPE controls the default search engine, making it impossible to change the search engine’s keyword to ‘null’. Again, this problem only occurred in non-Tor private windows.

How can this issue be reproduced?
1 Launch Brave
2 Install DDGPE
3 Navigate to chrome://extensions/ and under DDGPE’s ‘Details’ turn on ‘Allow in private’
4 Open non-Tor private window (Ctrl+Shift+N)
5 Try hitting a key, e.g. typing in address bar or opening new tab (Ctrl+T)
6a Currently this will crash Brave
6b Formerly (until at least Brave version 63) your hotkeys would work, but if you typed a search term in the address bar which was one word with no URL-forbidden characters, Brave would try to connect to http://[search term]/
6c Formerly (until at least Brave version 63) your hotkeys would work, but if you typed a search term in the address bar which included spaces or other URL-forbidden characters, nothing would happen

Expected result:
Just like in regular windows or Tor private windows, hotkeys should perform their function, and typing a search term in the address bar should connect you to https://duckduckgo.com/?q=[search term]

Reproduces how often:
Every single time

Brave Version( check About Brave):
Version 0.68.139 Chromium: 77.0.3865.90 (Official Build) (64-bit)
Windows 8.1 (64-bit), Ubuntu 18.04 (64-bit)

Additional Information:
See also previous topics on these subjects, which never received any replies from staff:



1 Like

Since I see that this topic is already getting buried, again without any replies, I am tagging in some people to discuss this issue, which is quite a serious nuisance about using Brave at the moment.

People who have reported this same issue: @AX3M , @zblues
People who have expressed an interest in this topic: @mk7z
Brave staff who have been recently active in the Desktop support section: @Mattches , @sriram , @eljuno , @steeven , @asad , @alex , @gsarvadnya

2 Likes

Hi @Go-go_duck. Thanks for the details on the issue and thanks for linking the older issues. Apologies that the issue got missed. I can’t seem to reproduce the issue. Here’s my recording on a clean install on Windows 7 and upgrade on Windows 8.1. You can see even with hotkeys the browser doesn’t seem to crash.

Windows 7:Windows7_DDGPE
Windows 8.1:windows81_DDGPE

Could you provide a few details? What is the privacy setting in shields set at? Do you have cookies set to block all or block 3rd party or block all? Do you have rewards enabled? Do you have sync enabled?

4 Likes

Hi @sriram , thanks for your reply! I’m surprised (and encouraged) to see how smoothly it performs for you. Could you please also try typing some terms in the address bar (not a URL) with and without space?

My shields settings are shown here:


I am only blocking cross site cookies, but I clear all cookies upon quitting Brave.
I do NOT have rewards enabled.
I do NOT have sync enabled.

1 Like

No I am still not able to reproduce the crash. Have the exact same shields settings as well. @Go-go_duck I do see a couple more extensions in your browser. Could you try disabling them one by one and see if the crash stops? I know one of them in uBO but not sure the one in the middle. Are both of those extensions allowed to work in private mode as well? If so could you try these steps

  • Disable Private mode on both extensions one by one and see if it fixes crash
  • If that doesn’t fix, disable the extensions one by one and see if that fixes the crash
2 Likes

@sriram , thanks for your response.

The middle extension is uBO Extra.

Both uBO and uBO Extra are allowed in private mode as well, but I’ve tried:

  • Disabling them in private mode
  • Disabling them altogether
  • Removing them altogether (so that I’m sure the only extension installed is DDGPE)

None of these, prevents the crashes from occurring. But disabling DDGPE in private mode does stop the crashes, regardless of whether uBO and uBO Extra are enabled or not.

This is just me and I didn’t test it for your issue, but I gave up on DDGPE as I had too many issues with stability while using other extensions. I was using a different fork of Chrome, so take it with a grain of salt. Plus the biggest issue I had with DDGPE was that testing it on various browser test sites as the only extension, it would work one time, and in the next run it would stall and I’d get a result like it was not installed or it was disabled. I just think DDGPE is too buggy for regular use yet.

I am sure it will all get sorted eventually.

1 Like

Interesting. I had no idea Chromium DDGPE had so many stability problems. I went straight from Firefox to Brave, after the great add-on-pocalypse several months back, and on Firefox DDGPE is (as far as I ever noticed) completely stable.

So one thing is clear, the other extensions are not affecting the behaviour of DDGPE. Am suspecting that the extension is probably trying to use some API calls that is restricted and probably blocked by Brave but not on other Chromum browsers. @Go-go_duck Could you try backing up your profile and then launch a new profile and try with just DDGPE? You can easily just rename the browser profile and launch a new one
To rename profile just do the following

  1. open %userprofile%/appdata/local/BraveSoftware/
  2. Rename Brave-Browser to Brave-Browser _DDGPECrash
  3. Click on brave icon will launch a new browser profile
  4. Install DDGPE and check if it crashes like before
  5. You can delete the new Brave-Browser profile and rename Brave-Browser_DDGPECrash to get back your old profile

Please only do this if you are comfortable. Anything wrongly done can mess up you existing profile

1 Like

@sriram Thank you for walking me through this :slight_smile:

It doesn’t work quite like you suggested though: if I follow your instructions, Brave does not launch a new profile, so my extensions and settings are still there. It turns out, it is in fact very difficult to get rid of your profile.

What ended up working for me was the following:

  1. Close Brave
  2. Kill Brave update process with Task Manager
  3. Navigate to %userprofile%/appdata/local/BraveSoftware/
  4. Zip the Brave-Browser and Update directories
  5. Move the zipped directories to a different disk partition
  6. Uninstall Brave from Windows, including removing browser data
  7. Permanently delete all Brave files and directories remaining in %userprofile%/appdata/local/BraveSoftware/
  8. Reboot the computer
  9. Reinstall Brave
  10. Launch Brave with a new profile

Now, I strongly urge anyone trying this to first export their Bookmarks as an HTML-file, because all my Bookmarks and Settings had been lost upon restoration of the zipped directories! (Don’t worry about me, I understood and accepted the risks :wink: )

What I found was this:
Your hypothesis seems to be correct, because in the new profile with only DDGPE installed and enabled in private mode, I could type inside private windows without Brave crashing!
In fact, the result was exactly the same as I experienced previously (described in steps 6b and 6c of my original post here, and in my previous thread ).

@sriram So, now that we’ve established it is better to disable DDGPE in private mode (for now), my next question is: Is there any way to stop DDGPE from overriding search engine’s keywords, or to override DDGPE’s choice of keywords? If so, how? If not, is there some way to fix this from Brave’s end, or would this have to come from DuckDuckGo?

Ideally speaking it’s better not to enable extensions in private mode. As far as I can tell in this situation its not an issue with the extension itself probably something to do with the browser profile having a compatibility issue with a specific version of the extension. A good practice when something is failing esp with extension is to check for an update or uninstall and reinstall the extension. (of course, this comes with a problem of losing states that are saved in the extension)

This is very subjective. It depends on the API calls the extension is doing and some API’s are not allowed to run in Brave due to security concerns. It would be good to check with the extension developer as to what is causing the issues since browser works just fine without the extension.

1 Like

You’ve been very helpful, thank you so much!
This level of support and engagement, is one of the reasons I switched from Firefox to Brave without looking back. Thank you guys for a great browser and community.

1 Like

@Go-go_duck you are welcome. Glad that we were able to work this one out. Hopefully, the issue is resolved for now. Will close this thread for now. Please open a new thread if you still run into any issues. For others marked in the thread who are using DDGPE I would suggest uninstalling the extension and reinstalling it.

1 Like