Brave Talk audio issues - how to output "original audio" with no filters?

I tested Brave Talk with “noise Suppression” OFF because I am inputting the audio from the Voicemeeter Potato Mixer (mixing background music and the voice from my Sure MV7 mic)

The result though is not as great as with the “Zoom” software.
The background music gets suppressed and the voice amped. I wonder if there is a default filter even with noise suppression OFF ?
Is there anything I should check?
In Zoom, with the same settings and “Original Audio” ON, the result is perfect.
There is no “Original Audio” option in Brave Talk but I though disabling noise suppression would do the trick.

I am on
WIndows 10 - 64 Bit
Brave 114.0.5735.198
Voicemeeter Potato
Microphone SURE MV7

Thanks for any input on this