Brave sync on iOS is completely broken and has been for many months! - plus other bugs with sync on iOS too. (iOS) If you have iOS please read!

Can you elaborate on your experience, please?

Do you have a desktop (Windows or macOS?) on the same sync-chain, and if so what are the Sync settings you have enabled on both the desktop and your iOS device? In my tests, I had Bookmarks and History enabled on both devices.

Do you see desktop bookmarks and history syncing through to iOS, but nothing from iOS making its way to desktop?

I have the up to date deb version of Brave on the lastest version of linux mint all boxes are ticked, plus Brave on two Android 11 devices all boxes ticked and Brave on iPadOS (lastest update) both history and bookmarks are ticked.
All on the same sync chain.
Linux and Android devices sync flawlessly. But Brave on iPadOS looses sync after twenty four hours or so

1 Like

Can you confirm the following scenario for me?

  1. Ensure that Bookmark-sync is enabled on desktop and iOS.
  2. Navigate to brave.com on desktop and bookmark (place bookmark within Bookmarks directory) the site.
  3. Wait up to 5 minutes and see if the bookmark appears on iOS.

One of your colleagues asked for us to do the same thing in another thread:

1 Like

I have done that about 70-90 times so far (no joke)
It doesn’t work
iOS loses sync after gaining it. So if you add it to the chain, it will lose sync after that first sync.
It loses sync as soon as it had synced. I found it loses sync instantly so no bookmarks added AFTER the sync are ever synced.
Never used to happen either, only started happening a couple of months ago.

it was after the latest update i think

I agree. I followed all of Brave’s instructions to sync my Mac desktop, iPad, and iPhone. The chain holds for a day, and then it breaks by itself. I like this browser, but I may have to go back to Firefox or another browser that allows you to sync bookmarks without this kind of flaw.

Bit late but retweeted Heather.

1 Like

Hi Sampson - realise you need to follow a process but as others have mentioned this has all been followed before, and issues can take 24 hours or so to appear. Have you read through all the posts from the last 2 months since Heather created the thread? Including some of mine (quoted below). I am an ex-IT Professional so consider myself at least vaguely competent with what info I provide - also a bit concerned for example you have ‘tested’ by having Traffic for both Brave Nightly on Windows, and Brave on iOS, passed through the Web Proxy Debugger Fiddler Classic (by Telerik) as this clearly isn’t the normal real world scenario the rest of us are in, for most of us we wont be passing our traffic through any proxies or debugging software - I realise this may help identify an (internal) issue but it won’t show if there is one for those of us in the real world environment (i.e. something is breaking the sync comms in real world environments).

Note also my posts quoted below where I have clearly established there is no obvious bug with an older version of Brave running on my older iOS device (iPad Mini 2) and yet there is clearly an issue with my newer device (iPhone 12 Pro Max with latest iOS and Brave). So clearly something is different between them whether its the Brave version (post 1.24) or a side effect of Brave interacting with the iOS version on each of the devices, its clearly not iOS per se, but an issue with the newer version(s) of Brave and/or iOS.

And this is obviously without even looking into the app freezing on the QR Code Camera Screen issue.

1 Like

my sync is back working after the 1.34 update :grinning:

no, i was wrong sorry.

after the update its synced once when Brave was opened for the first time and hasn’t since

1 Like

This is broken for me too. Removing and re-attaching the iPhone from the sync chain works. But, then, new bookmarks added on the desktop side are not synced to the iPhone.

Sorry but considering how serious this issue is, can we please get the attention of some developers to try and work on it? It’s been bloody ages. And this is the first post in the Sync section with the most replies.

I’ve had the exact same issues mentioned on iPadOS for months now. Always losing sync. I’m on the verge of switching to Firefox despite my take on Mozilla and their failings in the mobile browser space and questionable decisions. Simply because their sync solution actually works on iOS / iPadOS.

I know it’s not easy, but maybe some communication is appreciated.

I’m sure so many people had the same problem as well. Not everyone will take the effort to bother and write a post or reply in the forums. They’ll just delete the app and move on.

2 Likes

I know I spoke to 2 devs on Twitter but after the initial contact where they said they were trying to replicate it, I didn’t hear back.
I had tweeted some of the devs directly as many of them are great at replying.
Haven’t heard back for a while.

This really is seriously as sync is totally useless on iOS now.

I really hope this is fixed soon. Been many months this has been happening and my steps are 100% reproduceable every time as everyone has confirmed.

3 issues all with sync on iOS that have been happening for a long time now.

Please can we have an update on if a fix is being worked on. Would be really helpful.

1 Like

this is a very serious issue, sync is always broken on iOS. I need to resync with my desktop browser very often. very uncomfortable.

I hope Brave put this to a high priority issue.

I had synced my iOS sometime last year. I thought it worked fine.

But last week, I was surprised to find my bookmarks were not updated - Sync had disconnected. I tried to resync, it worked, but I got tons of duplicate bookmarks.

Now today I tried to check my sync status, and it was disconnected again!

What is going on, Brave? Maybe you should put “Fix iOS Sync” on your 2022 Roadmap, instead of NFT Wallets.

But it seems basic browser sync is not as sexy as DeFi, Web3.0, NFT, Metaverse. :money_mouth_face:

6 Likes

I started using brave a few weeks ago. I’m sorry to report I have the same sync issue. First it worked for a while, maybe a few days, now I don’t see my added bookmarks appear on my laptops or the other way around. History seems to have never synced.
I have one iPhone and two laptops in my sync chain. One laptop running windows 10, the other Manjaro Linux.

Yep, works for 1 sync event. Subsequently adding/editing/arranging bookmark(s) on any device in my sync chain (M1 MacBook Pro, iPad Pro, iPhone) will not sync on the others. Deleting and restoring the chain will sync devices then but any bookmark change thereafter - zero…no sync.
MacOS Monterrey, iOS 15 will all updates. For the past couple of years sync worked flawlessly. I believe the latest OS annual updates this past Fall (Monterrey and iOS15) broke sync.

Well said music - couldn’t agree more.

Please can the devs make this a priority and comment on here to let us know you are working on it?

I reported it back in November now on here and to some devs on Twitter.

I was told by Jimmy and Sampson that they were trying to replicate it but this is still happening.

The steps I posted are easy to follow. Detailed, but easy to follow.
I can add more info if needed although everyone said the steps I posted do replicate the issue so I would hope that maybe it is being worked on, although I haven’t heard anything.

Can the devs give us an update and assure us this is being worked on as a priority?

Sync on iOS is totally unusable so this is very important.