Brave Sync not working on Fedora 38 KDE after version 1.51.110

Description of the issue: After updating the Brave browser to version 1.51.110 on Fedora 38 KDE the Brave Sync feature is no longer functioning. Going to the sync page in settings you get a message saying “Could not sync Brave on your devices.” The details below say, “Brave could not access your operating system’s safe storage. This is what’s used to secure data such as passwords and cookies; it’s also required for Brave Sync to connect your browser profile between devices. This means Brave Sync is not running.” The Brave help page says to make sure the login keyring is unlocked for Brave sync to work, but it is already unlocked on my system. I have also been able to reproduce this bug on another Fedora 38 system by updating the browser to the same version. This bug is in addition to fractional scaling support being broken in both Wayland and Xorg.

Steps to Reproduce: 1. Update Brave to version 1.51.110 2. Go to Brave Sync in settings 3. View the error message.

Reproduces how often: 100% of the time. The Brave Sync feature never works in this version of the browser.

Brave Version:
Version 1.51.110 Chromium: 113.0.5672.77 (Official Build) (64-bit)

Type of devices currently running on the Sync chain in question: One desktop PC with Fedora 38 KDE, One laptop with Fedora 38 KDE, and one Google Pixel 7 with Android 13 (no sync issues on the Pixel 7).

Additional Information: As I mentioned above in the description, there is also a bug with fractional scaling on both Wayland and Xorg with this version. I did not create a separate topic for it because I could see someone already has. I just felt like I would bring it up because they could be connected. They both started immediately after updating the Brave browser to the latest version. Since the fractional scaling bug makes the browser unusable, I have downgraded the Brave version and version-locked it on my laptop where I need fractional scaling. I can get along without sync temporarily, so I have left my desktop on the latest version.