Brave Sync don't work when multiple profile

Release Notes V1.27.109 (July 27, 2021)

on Windows 10

Well, nothing sync, nothing works
I try to sync everything = don’t work
I try to customize and only sync my bookmark == don’t work
I try to remove device from the sync == don’t work
I try to leave the Sync Chain == don’t work

I mean when I go back to Sync Tab everything remain the same

What does it show when you click Sync Everything?

1 Like

it doesn’t keep any option, when I leave the sync setting tab and come back I have to select it again

1 Like

Oh I see…

I am actually confused because I haven’t faced that issue before and I haven’t seen other’s have that problem too…

I’m having the same problem. Fedora Linux 64 bit. Brave not saving any changes, cannot change sync settings nor can I quit the chain or remove devices from the chain.

1 Like

Just by curiosity,

  • do you have multiple profile under Brave ?
  • did you reuse the same Sync Passphrase ?

Personally I simply, left the Sync when it was possible and on the devices were it was’nt I reinstall Brave after I flushed everything related to Brave such as ie: [./config/Brave, .local/…]

I think I messed out with Brave Sync because I saved the Sync Passphrase in my Vault and reuse it to sync multiple device, while this time I realized they the Sync Passphrase is different every time you sync a new device.

Even after resetting all my device and restarting synching this issue came back on my Debian
My mac, my Android and my Windows sync but not my Debian

It is exactly the same on my Debian
when I try to sync anything or simply the bookmark
the option don’t stick to my choice.

Now I’m having: Release Notes V1.28.105 (Aug 11, 2021) on my Debian bullseye with KDE.

It is almost a running joke, every 2weeks I have to reset my Brave Sync
Here again this morning, I noticed my bookmark did’nt sync between my phone and my Debian Laptop. nobody have an idea ?

So I got it again; and I was, hum, last week it was working and then this weekend it stop, what change doc ?

Basically; Brave sync everything between my iPad, 2 Android, 2 Ubuntu, 1 MacOS and 1 Windows since for ever and I have no complain until I create a second profile.
At the beginning I declared Debian/Linux probably because it is where I created the second profile (one for personal usage and one for work) but then this weekend I create a second profile on my Windows 10 for the same purpose and over the weekend same a bunch of bookmark via my 2 androids and the iPad.

This morning, Windows did’nt sync those, but all others devices are fine.
So my new conclusion is it happen only on the device with a second profile.

Yep, on my windows I had to rename User Data and restart again my Brave profile

@JOduMonT I feel you man…the same problem every 1-2 weeks… happens regardless OS ( Mac, Win ), and regardless how I connect ( remote host or local machine )

@macfanol thank for sharing, I thought I was alone :slight_smile:
do you have multiple profile ?

Yes, 4 profiles…

So since my last reset, I only have 1 profile and everything works fine,

@macfanol I’m surprised we are only 2 persons on the planet to use profile and sync :wink:

1 Like