Brave - Supported Sites: 0 (ZERO!) [Workaround?]

bug
#1

Potential workaround As noted in Brave - Supported Sites: 0 (ZERO!) [Workaround?], using Version 0.60.45, I set the “Minimum Visits for publisher relevancy” to 1, and the entire Auto-contribute history became visible.

Original report follows:

Using Brave Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit) on macOS 10.12.6:

I have been using Brave for several months, watching it keep track of the amount of time I have spent on the sites I browse. This is good.

Since around 6 Feb 2019, the Auto-contribute page shows ZERO supported sites. (see image below).

I’m sure the problem began around that time, because I posted a video of a different problem on 5Feb2019 on the forum at: Brave Rewards Auto-contribute site list has bugs that showed many sites had been accumulating attention. (NB: That earlier report used Brave Version 0.58.21.)

What other information could I provide to troubleshoot this? Many thanks.

Brave Rewards Auto-contribute site list has bugs
#2

I am also having a similar issue. After updating to 059.35. I previously had 8 verified sites in my contribution list. After the update all the sites were removed. I then went to another verified site and it was calculated like this.

image

Now that seems to be the only site that is allowed to be added to the list. Now lets see what happens after excluding “First We Feast” from the contribution list.

image

After a 45 second - 1 minute delay all the original sites show up again. If I attempt to add back “First We Feast” it deletes all the other sites again. It is also worth noting that all the sites from the list seem to be accumulating attention even when they don’t show up in the list. So if I am on DDG its percentage increases even while not in the list.

This is on Manjaro

#3

Could you both click on the settings icon in the auto contribute panel (the one that looks like 09%20PM and post a screenshot of your settings?

Thanks,
Lauren

#4

This shows both panes of the Brave settings, both screen shots are from the same time. I do not believe that I have changed any of the Auto-contribute Settings, and have certainly been browsing to many of the same sites for long enough during the last ~6 days.

I am happy to provide additional information (I’m a Javascript developer, and can peek into secret settings if need be.) Thanks!

Only 3.0 BAT contributed (not 30.0 as expected) [SOLVED]
#5

#6

@richb-hanover I think you might be encountering both https://github.com/brave/brave-browser/issues/2110 and https://github.com/brave/brave-browser/issues/3320. The second issue is currently scheduled to be fixed with 0.60.x and the first issue is currently slated for 0.61.x. We’re aiming to have 0.60.x out next week, so can we revisit once that fix lands and see if you are also being affected by issue 3320?

@drose2211 nothing on your settings is jumping out at me. We did fix https://github.com/brave/brave-browser/issues/3134 with 0.59.x (which was a problem with the minimum time set to 5s). I wonder if what you are seeing is related to this. I’ll try to dig in a bit but I don’t think we’d have a fix by 2/19 (your scheduled contribution date). I wonder if after that date your table will fix itself since the table clears once a contribution happens. I’ll try to reproduce from my side and if you could report back what happens after the 19th I’d appreciate it.

Thanks!
Lauren

#7

@LaurenWags - thanks for the update. I’ll wait for the next release.

1 Like
#8

thanks for your patience @richb-hanover, we’ll take it one problem at a time and do our best to get to the bottom of this!

#9

As we used to say in my company, “One insurmountable hurdle at a time…” Thanks again.

1 Like
#10

I will be sure to give you an update after the contribution date

1 Like
#11

Just wanted to send an update. Contribution was made. The rewards list has reset itself and seems to be working correctly. With that being said I have only tested a few sites and will bring it back up again if I find the issue has resurfaced.

#12

Thanks @drose2211 - definitely keep an eye on things. I’d recommend opening a new thread if you do see an issue since it’s probably different than what you had experienced before, feel free to tag me in it if need be.

1 Like
#13

@Laurenwags Update on my situation - Auto-contribute is still not working.

Brave auto-updated late last week to Version 0.60.45 Chromium: 72.0.3626.109 (Official Build) (64-bit) (I’m on MacOS 10.12.6)

I have been browsing as usual since then, but still see zero sites in Autocontribute.

In fact the Auto-contribute settings are substantially the same as in my initial report:

  • Monthly payment - 30BAT
  • Next Contribution Date - 3/8/2019
  • Supported Sites - Total 0
  • Minimum page time - 8 seconds (down from 1 minute before)
  • Minimum visits - 5 visits
  • Allow contribution to non-verified sites - checked
  • Allow contribution to videos - unchecked

What’s the next step in troubleshooting this? (I repeat my offer to rummage around for more information - I’m a Javascript developer.) Many thanks!

#14

Hey @richb-hanover

Thanks for reporting back. Since you still have visits set to 5, I still think you’re going to encounter this issue: https://github.com/brave/brave-browser/issues/2110 which is currently scheduled to be included in 0.61.x. Note - when this issue was written sites were added with 0% to the table. In a subsequent version, we changed this so that 0% sites don’t get added to the table (I believe it was with this issue - https://github.com/brave/brave-browser/issues/2365 which was included in 0.59.x) - I think this is why you are not seeing anything.

However, since you’re offering to poke around a bit more, I’d like to ask @nejczdovc to review this. @nejczdovc - any other information that @richb-hanover could provide?

Thanks!
Lauren

#15

As a workaround, I set the visits to 1, (leaving minimum page time at 8 seconds) and Presto! I now see 61 sites in Auto-contribute. That seemed to make the difference. Thanks!

#16

Great! Thanks for reporting back @richb-hanover. With 0.61.x hopefully your setting of 5 visits will work as expected. Please do check it out once that version is released and let us know how it’s going!

Thanks,
Lauren

#17

FYI @richb-hanover - just wanted to add an addendum re: https://github.com/brave/brave-browser/issues/2110 .

What I believe will happen is that if you have Minimum visits set to say 5, when you update from 0.60.x to 0.61.x your sites won’t be listed in auto contribute table. This is because 0.60.x and prior versions were not keeping track of the number of visits appropriately. However, once you visit the same site 5 times with 0.61.x, then it should be added to the a-c table because 0.61.x is counting visits appropriately. That’s been my experience thus far in testing this so I wanted to make sure I set your expectations appropriately. Definitely give it a try once 0.61.x is released and feel free to report back with what you’re seeing.

Thanks,
Lauren

closed #18

This topic was automatically closed after 30 days. New replies are no longer allowed.