Brave suddenly outdated/unsupported by EVERY site?


Description of the issue:

Google says Brave is no longer supported, and recommends other browsers. Google Images returns to a basic HTML layout, Spotify also does the same - it says the browser is far outdated and to upgrade to a supported browser.

How can this issue be reproduced?

  1. Download the latest version of Brave via APT on Ubuntu 20.10 Groovy Gorilla
  2. Open Brave and navigate to any site like Google or Spotify
  3. Observe issues

Expected result:

Before, the browser worked perfectly normal. No complaints from any site, and they rendered perfectly without refusing access or recommending upgrading to supported browsers.

Brave Version( check About Brave):

Version 1.20.103 Chromium: 88.0.4324.152 (Official Build) (64-bit)

Additional Information:

No updates to Brave happened before this issue occurred, and no distribution upgrades happened. This was done with Ubuntu Budgie 20.10 Groovy Gorilla, latest version of Brave installed via APT and Apt-Key (latest version on the Brave website, package version 1.20.103 or brave-browser_1.20.103_amd64.deb.

Hello @enigmapr0ject

could you try in private mode?

what about create new profile just for testing

hope that help and have a nice day :slight_smile:

@enigmapr0ject,
Something other than Brave itself is likely causing the conflict. @justsomeone1 is correct, you should try creating a new browser profile and testing to see if you get the same result when using the new profile.

1 Like

This seems to have worked, although I have absolutely no idea why.

Edit: seems clearing all browser data has worked.

1 Like

@enigmapr0ject,
My very next suggestion was to return to your original profile and try clearing your browsing data. “Bad bits” sometimes get stuck or corrupted in cache and can cause wonky behavior.

Glad you got this resolved.

1 Like