Brave suddenly completely unresponsive in Ubuntu 22.04.2 LTS

Description of the issue:

I have been using Brave for many years without any issues and suddenly today it became toally unresponsive. No tabs working, it just keeps loading. Not even settings work. I am on Ubuntu 22.04.2 LTS.

I have tried booting it up in the terminal with the following switches:

None of these work… BUT it works if I run:
brave-browser --v=1

then everything looks normal and it all works.
But why do I suddenly have to run it like this?

Before Brave crashed I messed with some Firefox and some CA certificates because I was trying to make Citrix Workspace work.
I used some of the following commands:
sudo cp /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/
sudo rename ‘s/.crt/.pem/’ /opt/Citrix/ICAClient/keystore/cacerts/*.crt
sudo /opt/Citrix/ICAClient/util/ctx_rehash
sudo rm -rfv /opt/Citrix/ICAClient/keystore/cacerts
sudo ln -s /etc/ssl/certs cacerts

sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/
sudo c_rehash /opt/Citrix/ICAClient/keystore/cacerts
cd /opt/Citrix/ICAClient/keystore/cacerts
sudo find -type l -delete

Might I have broken/corrupted something that leads to Brave/Chrome not working anymore?

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Everytime I open Brave

Operating System and Brave Version(See the About Brave page in the main menu):
Ubuntu 22.04.2 LTS, Brave Browser
Additional Information:


this is happening to me too… although i can’t even make it work with the “brave-browser --v=1” you mentioned

This happened to me as well on two different machines, running Ubuntu 22.04. On one, Chrome also died, but Brave-beta works. On another Chrome works but Brave and Brave-beta do not. All this happened after Ubuntu sent out ca-certificate updates. Coincidence? Maybe. Another weird thing is that in Xorg, virtually nothing comes up, even a local page like Settings. In Wayland, it will render pictures, but not text.

I got a bug tracker e-mail from Ubuntu and it seems that the problem may be caused by an update to the gpu driver mesa. Try running brave (or chrome or chromium) from the command line with the option --disable-gpu. Once Brave comes up, you can then get into settings and disable hardware acceleration. It works for me for Chrome, Brave, and Brave-beta. Hopefully, and updated mesa will fix this.

Me, too. I cannot get any web pages to fully render as of this morning. I have another Chromium based browser running everything, so this is not an Internet/DNS issue. This is Brave specific. I followed the uninstall and reinstall procedure for Brave Browser and no luck. I am running Linux Lite 6.4, which runs on the Ubuntu 22.04 LTS base.

I used the following:
From a terminal, I typed, “brave-browser --disable-gpu”. It opened a Brave session, and I went to settings. I did a search for the word “acceleration” and I clicked on Relaunch to re-open Brave with Hardware Acceleration turned off.

Hey everyone, I actually managed to solve this by simply updating to the, at that point, newest version of Brave which is “Brave Browser”. Then it suddenly just worked again. It might also work with the newest version of Brave, but I haven’t tried that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.