Brave slows computer to a crawl

Has anyone else experienced Brave slowing down the computer (Windows 11)? I played with Brave’s hardware acceleration settings and flags, as I read in the forums. However, as soon as I would start Brave, it would slow the computer to a crawl. It even slowed the mouse. It was bad to the point I could hardly click on objects. The performance hit would last even after closing down Brave until reboot. During this year, I have installed and removed Brave 3 times, each time with worse performance. I did not experience any issues with the other browsers I tried (Firefox, LibreWolf, Opera, Vivaldi, Edge, Chrome, and Chromium). Fortunately, uninstalling Brave was never a problem and restored performance each time.

1 Like

@Alice2095 @Kevin_cc @Jarc-1107 Please help. Thanks

Same problem I have one year ago with brave .
But actually problem from battery but brave slow down…

Others browsers ok.

After i removed battry then brave running ok.

Hello there @_NM sorry to hear you are experiencing performance issues with Brave.

Has the issue repeated after you completed a reinstallation? If that’s the case, please provide the following information in order to investigate further:

  1. Description of the issue:

  2. Steps to Reproduce (add as many as necessary):1.2.3.

  3. Actual Result (gifs and screenshots are welcome!):

  4. Expected result:

  5. Reproduces how often:

  6. Operating System and Brave Version(See the About Brave page in the main menu): Additional Information:‘’

Be waiting for your response.
Regards.

@Deepak: My battery is OK.
@Kevon_cc: Issue is slowing the computer running 64-bit Windows Pro with Intel 9th generation i9 and NVIDIA GeForce GTX 1050 graphics card. The task manager would show 100% GPU use. The problem repeatedly recurred with Brave installation and resolved after its removal. I no longer have Brave installed and as long as I can find other users describing the same issue, no intention of ever installing it again. The Brave version was the latest as of 12 days ago when I first posted. And yes, the issue would occur every time I started Brave, without exception, and with repeated installations.

1 Like

Hi again @_NM, does this CPU usage happens if you open a differente set of tabs on Brave or just by opening one window? If it happens with a certain amount of tabs, I kindly suggest you, if you install Brave again, open the same tabs on a different browser to see if the memory usage shows the same on task manager.

If its only with one tab, try opening your main profile in private or guest mode to see if the issue persist? If it does not happen, try disabling your extensions to see if this is the cause of the issue.

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.
Regards.

Thanks for the follow-up. I did not get to installing any extensions. The PC would nearly freeze with a single opened tab after opening Brave and visiting a website. I never got to opening additional tabs. Since it affected all websites, I do not think it was server/website related. I would always switch to a different browser and continue without problems. The slowing of the PC was so severe that I worried about the integrity of other system processes that might time out and lead to file/disc corruption. It was always a relief when the task manager would finally come on to allow me to shut Brave down.

1 Like

@_NM,
Can you please clarify whether or not disabling (or enabling) Hardware Acceleration in the browser has any effect (in either direction)?

I’ve had it happen a couple times on my Mac. But typically if I just restart the computer it’s good to go.

@_NM

You could try disabling or enabling Hardware Acceleration in settings to see if this resolves the issue. You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Be waiting for your response.

Thank you. I had already tried that before posting. I also followed recommendations about setting individual flags.

1 Like

Hello there @_NM could you please try updating to the latest version on your device to see if the performance issue solves?

Regards.