Brave Shields interact poorly with local web content


#1

I recently created a simple web page as a tool, but I notice some odd and inconvenient behavior when viewing it in Brave (I’m opening the html file directly from my desktop). The Brave Shields icon/button is grayed out as if shields were disabled, but javascript is being blocked (I confirmed this by enabling scripts in my global settings and reloading my page: javascript works or is blocked according to my global settings). Moreover, clicking the Brave Shields icon/button does not open the Site Shields Settings controls.


#2

Shields is not enabled for local files. Blocking javascript is expected on local files if it is enabled at global settings. For the shields to work on local web page it needs to be hosted and opened via the localhost/web server address.

Is there anything specific that you are trying to achieve with shields for the local file. If you can provide more info on this that would be helpful.


#3

I want javascript to work in the local file, but not on web pages I’m visiting for the first time. Right now, to use the local file I close every tab with a web page I haven’t specifically enabled scripts on, enable scripts globally, use the local file, disable scripts globally, and reopen the closed tabs. It’s… inconvenient.


Brave Shields settings for local web content
#4

Unfortunately there is no work around available for now. The only option that I can think of is to enable block javascript globally so that its not enabled on the sites you visit and only when you need the local file you can disable shields settings and load the file. Sorry for the inconvenience.


#5

I’ve found a less frustrating work-around that I’ll use while waiting for a proper fix. I’ve noticed the security settings for the local page copy the global settings when the page is loaded and keep those settings until the page is reloaded, so as long as I never reload the page, it’s only necessary to go through the disable-load-enable ritual once per browser session rather than once per page use.


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.