Brave Shield: Videos cannot be played back

Description of the issue: Brave Schild: Videos cannot be played back

Steps to Reproduce:

  1. Open instant-gaming.com
  2. Open any subpage (e.g.: https://www.instant-gaming.com/de/2249-kaufen-key-uplay-anno-1800/)

Actual Result :

Expected result: The video should be playable

Reproduces how often: Always

Operating System and Brave Version: Windows 10 October 2018 Update, Brave: 0.62.51

Additional Information:
The message inside the black box, in which a video should be available, says here (translated): We are sorry.
Due to its own privacy settings, this video cannot be played here.

If I open the page e.g. with Firefox, I can play the video without any problems. Every page on instant-gaming.com where you can buy games is affected by this problem.

With shields disabled, playing the video works fine.

instant-gaming.com support said that you are using Vimeo as a video service, but Brave might have problems with that.

Translated with www.DeepL.com/Translator

@MediaBird,
I do in fact see the same behavior on my end – however, instead of dropping Shields entirely, allowing cookies will also initiate video playback:


I’ll make sure the devs get eyes on this though – I don’t think you should have to adjust shields in instances like this. Thank you for pointing it out.

1 Like

Any solution in sight?
Still getting this problem on the Athlean-X website.

Thanks in advance for an update.

@MrRB,
Ol’ Jeff Cavalier – He does have some good workouts!
For athleanx.com, you can again open your Shields panel and set the Cookie control to Allow all cookies to initiate video playback.

Will have to keep digging on why this is but Vimeo has been known to have issues like this when it comes to cross-site compatibility

1 Like

Thanks for the tip and the quick reply @Mattches. Unfortunately, I’ve allowed the website as an exception, but no luck…

For now I’ll open it in Chrome, but a solution would be handier, because I set Brave as my default browser today.

@MrRB
Hi, if it’s not so easy to handle the Brave shield, you could also disable the shield completely for this page. Does it work then?

@MediaBird @Mattches Allowing all the cookies indeed worked. Thanks!
However that means all cookies are now allowed for every website, right?

Only for the page on which you have enabled cookies and their “subpages” (if you call them that).

@MrRB,
There are both site specific and global Shields settings – global defaults for Shields are set in Settings --> Default Shields and the lion icon in the address bar is used for site-specific settings:

I would highly recommend taking a look at our Shields documentation for a better understanding on how they function.



This topic was automatically closed after 30 days. New replies are no longer allowed.