Brave shield UI bug


I’m facing this bug on Brave Beta on every website. I tried closing and opening Brave again but didn’t work.

OS: Manjaro Linux.

Text color sometimes renders white in pages and always in the brave button

Same issue here on Manjaro


Same, also Manjaro:



Sorry for the late response. @prinzvonlicht, thanks for reporting! @hello, thank you as well - also great job landing that user name!

I’m going to test this and see if I can reproduce myself and see if anyone on the team is seeing this happen as well. Has it always displayed this way?


Thank you @Mattches :grinning:

For me it has been since the switch from Muon to Chromium. I switched yesterday.


I have this issue since I switched from Muon to Chromium as well as @hello.


Do other extensions show UI or is this specific to Shields?


@sriram others work:


It only happens with Shields. uBlock Origin display its inteface well. I tried reinstalling Brave but it didn’t work either.


Making @clifton for more info.


UPDATE: The package brave-beta-bin was updated to 0.55.10-3 the 4th of October but it still has the same issue.


Same issue after update to 0.55.10-3


Note to thread:

Haven’t forgotten about you guys! Working on getting an issue open for this right now. Thank you for your patience.


Oh, for anyone interested, I’m curious about the BAT/Rewards icon in the URL bar next to Shields. Does the dropdown appear as intended or is it missing elements/text the same way the Shields dropdown is?


Issue opened for this. Thank you all for reaching out about this and for being patient as we get things loged in the right place:


It may be linked to text color, as this bug effects pastebin. Im on normal Arch, but I think that Manjaro has a dark theme. I also have one, so default text colour may be the issue.


Or it could be using pamac is the issue (good package manager, but I used it on normal arch and here we are)


Big thanks for not letting us die! :grinning: I hope it gets fixed soon.


I have it enabled but icon is not displaying. I disabled auto-contribute, though. I don’t know if it is that the cause.